The height of PDF frame is too small on IEEE Xplore

RESOLVED WORKSFORME

Status

()

P3
minor
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: arai, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(Whiteboard: [parity-webkit][parity-chrome])

(Reporter)

Description

2 years ago
Steps to reproduce:
  1. open Nightly 57.0a1 (2017-09-06) (64-bit) with clean profile on macOS
  2. open http://ieeexplore.ieee.org/stamp/stamp.jsp?arnumber=6889777

Actual result:
  the height of the PDF frame is too small

Expected result:
  the height of the PDF frame fills the bottom side of content area

it works as expected on chrome and safari.

the iframe has `height: calc(100% - 73px);` rule, but it doesn't fill the content area.
adding `body{ height: 100%; }` style fixed the issue, so this might be just the website's issue and tech evangelism issue tho.

might be related to bug 243751.
Priority: -- → P3
(Reporter)

Comment 1

a year ago
The issue is no more reproducible on the URL,
apparently the website added some style rule.
there's still `height: calc(100% - 73px);`, but the issue doesn't happen on nightly 2017-09-06.

disabling `position: fixed` on iframe reproduces the issue, so I think it's somehow related.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.