Closed Bug 1397583 Opened 2 years ago Closed 2 years ago

With compact UI density, urlbar animations for Pocket and bookmark star are in the wrong place (offset to the right of the normal icon)

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- fixed

People

(Reporter: adw, Assigned: adw)

References

Details

(Keywords: regression, Whiteboard: [reserve-photon-animation])

Attachments

(1 file)

When the UI density is compact, the bookmark star and Pocket animations are shifted to the right, like they were in bug 1390182.  It doesn't look like the related CSS handles :root[uidensity] specially, for margins and such, so maybe it should?

I noticed this while working on bug 1397278.
Summary: urlbar animations for Pocket and bookmark star are in the wrong place (offset to the right of the normal icon) → With compact UI density, urlbar animations for Pocket and bookmark star are in the wrong place (offset to the right of the normal icon)
Whiteboard: [photon-animation][triage]
Flags: qe-verify+
Priority: -- → P4
QA Contact: stefan.georgiev
Whiteboard: [photon-animation][triage] → [reserve-photon-animation]
This is an easy fix, and I'm familiar with this CSS now, so I went ahead and made it.
Comment on attachment 8905620 [details]
Bug 1397583 - With compact UI density, urlbar animations for Pocket and bookmark star are in the wrong place (offset to the right of the normal icon).

https://reviewboard.mozilla.org/r/177418/#review182436

Thanks for fixing this!
Attachment #8905620 - Flags: review?(jaws) → review+
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6bb535da41e5
With compact UI density, urlbar animations for Pocket and bookmark star are in the wrong place (offset to the right of the normal icon). r=jaws
Assignee: nobody → adw
Status: NEW → ASSIGNED
I see this is marked as blocking bug 1387077 -- not sure what that signifies or if that's correct, but this regressed much more recently than when bug 1387077 landed.

As identified on dupe bug 1397903 (via mozregression), this compact-density issue is a regression from bug 1388589. Marking as such.

(I'm glad to see a fix has landed already - thanks for the fast work!)
Blocks: 1388589
Keywords: regression
https://hg.mozilla.org/mozilla-central/rev/6bb535da41e5
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Iteration: --- → 57.3 - Sep 19
Priority: P4 → P1
I was able to reproduce the issue with compact UI density using Nightly build: 20170906100107.

Build   ID    20170908100218
User Agent     	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

This bug is Verified with latest Nightly 57.0a1.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Version: unspecified → Trunk
Depends on: 1400751
You need to log in before you can comment on or make changes to this bug.