Colors pref panel reads "Use Windows Colors"

VERIFIED FIXED

Status

defect
P2
normal
VERIFIED FIXED
20 years ago
8 years ago

People

(Reporter: mikepinkerton, Assigned: bugzilla)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

Go to the Colors panel under appearance in prefs. One of the checkboxes says,
"Use Windows Colors." How it's going to jump across the network to my windows box
to get these colors is beyond me. Pretty neat trick if it can.

Stuff like this will get us put straight in the trash can.

Updated

20 years ago
Assignee: shuang → matt

Comment 1

20 years ago
More importantly, as seamonkey has no support for Windows desktop themes... what
the heck is this doing in the prefs? :) Probably just a holdover/placeholder
from 4.x Win32 UI. Reassigning to matt who's better equipped to deal with it.

BTW, pinkerton, why is there a Bookmarks | Macintosh Resources menu item on
Win32? :)
To educate all the windows folks as to what they're missing, of course ;) ;) ;)

Updated

20 years ago
OS: Mac System 8.5 → All
Hardware: Macintosh → All

Comment 3

20 years ago
... changing platform and OS to All ...

Updated

20 years ago
Severity: critical → normal
Priority: P3 → P2
Target Milestone: M12

Comment 4

20 years ago
Reducing severity to normal.  Give me a break, Pink.

Matt, take a look at this for M12 ...
what? me? overreact? never!

Sorry, this was the last in a string of heinous PP bugs and it was just the last
straw. ;)

Updated

20 years ago
Target Milestone: M12 → M13
The Mac equivalent would be `Use Internet Config colors' ... but `Use Internet
Config settings' should be a pref with wider scope than just the colors.

Updated

20 years ago
Target Milestone: M13 → M15

Comment 7

20 years ago
Worry about this later ...
(Assignee)

Updated

20 years ago
QA Contact: cpratt → sairuh
(Assignee)

Comment 8

20 years ago
spam: in my testing realm, so reassigning qa contact to me, en masse.
It's weirder than you think.

The label internally uses the term Windows.
The id if the control is WFEUseWindowsColors.
This gets mapped to a preference called: browser.wfe.use_windows_colors

In the end, in the file layout/base/src/nsPresContext.cpp, this pref is queried
only on Win32. The reason is because around line 84, the initial values for
foreground and background color are queried from Windows using Windows APIs, on
other platforms they are set to black and white. Then because the code to use
this pref is never compiled on any platform but WIN32, the colors get set
to the default Mozilla colors. So this checkbox does nothing on any
platform but Windows.

Do other platforms have a concept of default text color and default windows
background color that can be queried? I know OS/2 does, so there should at least
be some generic way to query these values from the OS rather than resorting to
WIN32 calls in the middle of layout here.

If only Win32 has this ability, I would almost think it would be better to
remove the checkbox completely and default to the Mozilla default colors.

Just my two cents.

Comment 10

20 years ago
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences

Comment 11

19 years ago
Move to M16 for now ...
Target Milestone: M15 → M16

Comment 12

19 years ago
Reassigning for Don
Assignee: matt → ben
Target Milestone: M16 → M17

Comment 13

19 years ago
Move to M20 target milestone.
Target Milestone: M17 → M21
Seems important to fix in nsbeta3 for polish, and to make us look slightly 
less foolish on our most doomed platform. ;) 

needs a platform specific overlay. probably simple, just tedious. 
Status: NEW → ASSIGNED
Keywords: nsbeta3

Comment 15

19 years ago
Nav triage team: [b3nav+]
Keywords: polish
Whiteboard: [b3nav+]

Comment 16

19 years ago
nav triage team: [b3nav+] now = [nsbeta3+]
Whiteboard: [b3nav+] → [nsbeta3+]
fixed!

Pink, where's my kiss? 
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Updated

19 years ago
Keywords: verifyme
(Assignee)

Comment 18

19 years ago
vrfy fixed using opt comm bits. linux/mac, 2000.08.14.12; winnt 2000.08.15.08.
Status: RESOLVED → VERIFIED
Keywords: verifyme
(Assignee)

Comment 19

19 years ago
h'm, perhaps i am/was hallucinating... but i need to double-check this on more 
recent Mac and linux bits --at least on mozilla.

asa/timeless, would you pls confirm that the "Use Windows colors" checkbox is 
indeed gone from the Mac and linux builds? (it's still there on win32 mozilla 
2000.08.24.08 on win98.) thanksthanksthanks.

gonna reopen and assign to me for the nonce...
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 20

19 years ago
if i was sane last week, i'll re-resolve this...
Assignee: ben → sairuh
Status: REOPENED → NEW
(Assignee)

Comment 21

19 years ago
'kay, just chatted w/asa who confirmed that it ain't there no mo' on mac. i'll 
verify the linux side tomorrow unless i hear back beforehand from others.

Comment 22

19 years ago
I don't see the windows colors thing on solaris8intel from 8/22.
Resolving fixed so se can mark verified.
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 23

19 years ago
whew. thx, guys.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.