Closed Bug 1397714 Opened 3 years ago Closed 3 years ago

wrap applySourceMap in the toolbox source map service proxy

Categories

(DevTools :: Framework, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 952127

People

(Reporter: tromey, Unassigned)

References

(Blocks 1 open bug)

Details

If the user prettifies a source in the debugger, locations in the console
should be updated to point to the prettified source.

When prettifying, the debugger will call the source map service's
"applySourceMap" method.  To get the console to notice, we'll
most likely need to (1) integrate the source map service proxy
https://dxr.mozilla.org/mozilla-central/rev/93dd2e456c0ecca00fb4d28744e88078a77deaf7/devtools/client/framework/toolbox.js#562
into the source map URL service
https://dxr.mozilla.org/mozilla-central/rev/93dd2e456c0ecca00fb4d28744e88078a77deaf7/devtools/client/framework/source-map-url-service.js#22

Then, calls to applySourceMap can simply notify location subscribers of changes.


This used to be https://github.com/devtools-html/debugger.html/issues/3777
and https://github.com/devtools-html/devtools-core/issues/352
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 952127
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.