'raw' directory listing format is confusing

VERIFIED FIXED in mozilla1.1alpha

Status

()

P2
major
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: bbaetz, Assigned: bbaetz)

Tracking

({polish})

Trunk
mozilla1.1alpha
x86
Linux
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
We're getting about one bug a day from people who select the 'raw' directory
listing pref in the debug pref panel, and then report that ftp directory
listings don't work, and just offer to display a file of type text/ftp-dir-

I'm considering just removing that item entirely. When I need that sort of
stuff, I just use ethereal, so it doesn't really help for debugging.

dougt - you added the backend for that, is that ok? Or should I add some big
warning text to that option?
(Assignee)

Comment 1

17 years ago
*** Bug 139780 has been marked as a duplicate of this bug. ***

Comment 2

17 years ago
If you can remove it by backing out one checkin, sure.

If not, just pref it out of the panel, but leave the underlying code in.

Comment 3

17 years ago
bradley - raw support is required.  Isn't the option in the debug panel?!
(Assignee)

Comment 4

17 years ago
When I said 'remove this item entirely' I mean 'remove this item from the pref
panel entirely'. Yes, its in the debug pref panel, but that hasn't stopped people.
we got a few bugs about debug prefs.
(i saw ~4 bugs about Debug XUL boxes")

How about a hidden pref that enables the Debug UI Entry ?
(an you would fix many stupid user bugs)

*** Bug 142342 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

17 years ago
Created attachment 82438 [details] [diff] [review]
patch

Lets just remove the option in the panel, but keep the dtd entry in there.

The values for the radio buttons are important, so I can't renumber.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: patch, polish, review
Priority: -- → P2
Target Milestone: --- → mozilla1.0.1

Updated

17 years ago
Attachment #82438 - Flags: review+

Comment 8

17 years ago
Comment on attachment 82438 [details] [diff] [review]
patch

r=dougt.

do you ahve to reset the value="" lines?

Comment 9

17 years ago
Comment on attachment 82438 [details] [diff] [review]
patch

sr=darin
Attachment #82438 - Flags: superreview+
(Assignee)

Comment 10

17 years ago
Checked in.

not going to take for 1.0.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Target Milestone: mozilla1.0.1 → mozilla1.1alpha

Comment 11

16 years ago
Verified that the 'raw' directory listing pref in the debug pref panel does not
appear in the trunk builds on Win2000, Linux, Mac OSX 10.2.2, or 9.2.2.
Status: RESOLVED → VERIFIED
QA Contact: benc → junruh
You need to log in before you can comment on or make changes to this bug.