5.03% Resident Memory (android-4-3-armv7-api16) regression on push 01d736f31b392d254f8e94abeaed56abbf621249 (Thu Sep 7 2017)

RESOLVED FIXED in Firefox 57

Status

()

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: jmaher, Assigned: smaug)

Tracking

({perf, regression})

53 Branch
mozilla57
perf, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

(Reporter)

Description

a year ago
We have detected an awsy regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=01d736f31b392d254f8e94abeaed56abbf621249

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  5%  Resident Memory summary android-4-3-armv7-api16 opt      199,354,613.25 -> 209,383,503.33


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=9288

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/AWSY
(Reporter)

Comment 1

a year ago
:smaug, I see that you authored the patch which has caused this regression, can you comment on if this is expected or we should look into it?
Flags: needinfo?(bugs)
Component: Untriaged → JavaScript: GC
Product: Firefox → Core
Interesting. Could this be because I removed the initial * 2 from the budget.
mccr8, would you r+ if I added * 2 back, like it was 
http://searchfox.org/mozilla-central/rev/67f38de2443e6b613d874fcf4d2cd1f2fc3d5e97/dom/base/nsJSEnvironment.cpp#1792 in case the method isn't called with a deadline?
Flags: needinfo?(bugs) → needinfo?(continuation)
(In reply to Olli Pettay [:smaug] from comment #2)
> Interesting. Could this be because I removed the initial * 2 from the budget.
> mccr8, would you r+ if I added * 2 back
r=me
Flags: needinfo?(continuation)

Comment 4

a year ago
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c855cf7aa13b
put back the higher GC budget when GC is triggered by a timer, r=mccr8
https://hg.mozilla.org/mozilla-central/rev/c855cf7aa13b
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Assignee: nobody → bugs
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox-esr52: --- → unaffected
Improvements noticed:

== Change summary for alert #9305 (as of September 07 2017 19:44 UTC) ==

Improvements:

  5%  Resident Memory summary android-api-16-gradle opt      208,964,356.38 -> 199,531,172.42

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=9305
You need to log in before you can comment on or make changes to this bug.