Custom tabs: fix loading pages

RESOLVED FIXED in Firefox 57

Status

()

Firefox for Android
GeckoView
P1
normal
RESOLVED FIXED
10 months ago
4 months ago

People

(Reporter: esawin, Assigned: esawin)

Tracking

51 Branch
Firefox 57
All
Android
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 months ago
In bug 1396065 we've extended GeckoView to support general URI load delegation but failed to update the onLoadUri callback for custom tabs to account for that.
(Assignee)

Comment 1

10 months ago
Created attachment 8905658 [details] [diff] [review]
0001-Bug-1397894-1.0-Fix-GeckoView-custom-tabs-URI-loadin.patch

Fire the generic view intent for external links and let Gecko handle the load otherwise.

We might want to extent the intent-based handling to links outside of the current domain.
Attachment #8905658 - Flags: review?(snorp)
(Assignee)

Comment 2

10 months ago
s/extent/extend
Attachment #8905658 - Flags: review?(snorp) → review+
Duplicate of this bug: 1397798

Comment 4

10 months ago
Pushed by esawin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/83d8880fbf0e
[1.0] Fix GeckoView custom tabs URI loading. r=snorp

Updated

10 months ago
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/83d8880fbf0e
Status: NEW → RESOLVED
Last Resolved: 9 months ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
You need to log in before you can comment on or make changes to this bug.