bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[meta] Fix ios10 deprecation warnings

RESOLVED FIXED

Status

()

Firefox for iOS
Browser
P3
normal
RESOLVED FIXED
10 months ago
8 months ago

People

(Reporter: farhan, Unassigned)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios10.0)

Details

(Whiteboard: [MobileCore])

Attachments

(3 attachments)

(Reporter)

Description

10 months ago
The following methods are deprecated. 

UILocalNotifications
UIUserNotificationSettings
UIColor.init(colorLiteralRed:green:blue:alpha:)
UIApplication.shared.openURL
OSSpinLock
Converting to meta.
tracking-fxios: ? → 10.0
Summary: Fix ios10 deprecation warnings → [meta] Fix ios10 deprecation warnings
Whiteboard: [MobileCore]
(Reporter)

Updated

10 months ago
Priority: -- → P3

Comment 2

9 months ago
Created attachment 8919237 [details] [review]
Pull request
Attachment #8919237 - Flags: review?(fpatel)
(Reporter)

Updated

9 months ago
Attachment #8919237 - Flags: review?(fpatel) → review?(jhugman)
Comment on attachment 8919237 [details] [review]
Pull request

Added some comments in the PR.
Attachment #8919237 - Flags: review?(jhugman) → feedback+

Updated

9 months ago
Attachment #8919237 - Flags: feedback+ → review?(jhugman)
(Reporter)

Updated

9 months ago
Duplicate of this bug: 1411126
Reminder that we need a follow-up to properly handle "Open in App" when web content attempts to deep-link into native apps.
The follow-up I'm referring to is in Bug 1396989.
Attachment #8919237 - Flags: review?(jhugman) → review+

Updated

9 months ago
Flags: needinfo?(jhugman)
Created attachment 8925534 [details] [review]
Link to Github pull-request: https://github.com/mozilla-mobile/firefox-ios/pull/3421

Unmodified version of original PR.
Flags: needinfo?(jhugman)
Attachment #8925534 - Flags: review+
Merged into master.

Callie D: Thank you so much for your contribution.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED

Updated

8 months ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 10

8 months ago
Created attachment 8926970 [details] [review]
Pull request

Follow up patch to fix an unlock becoming a lock.
Attachment #8926970 - Flags: review?(jdarcangelo)
Attachment #8926970 - Flags: review?(jdarcangelo) → review+

Comment 11

8 months ago
garvankeeley merged commit 049a351 into mozilla-mobile:master just now

Updated

8 months ago
Status: REOPENED → RESOLVED
Last Resolved: 8 months ago8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.