Crash in mozilla::dom::ChannelWrapperBinding::get_channel

RESOLVED DUPLICATE of bug 1398045

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1398045
2 months ago
2 months ago

People

(Reporter: Robin Whittleton, Unassigned)

Tracking

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

2 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170907220212

Steps to reproduce:

Visited http://witt.zone/sage/ and https://www.breville.com/


Actual results:

Not directly reproducable, but I’ve had three crashes with the signature mozilla::dom::ChannelWrapperBinding::get_channel in quick succession:

https://crash-stats.mozilla.com/report/index/fe42fecf-ec40-4f0b-b318-62e4b0170908
https://crash-stats.mozilla.com/report/index/6ef4a9c9-5bc2-45cd-8047-0dd170170908
https://crash-stats.mozilla.com/report/index/c3e31286-86e9-4693-adf9-f6f770170908

They took down the whole browser, not just that tab.


Expected results:

No crashes.

It could be specific to this site, but I haven’t seen this before and I’d just installed todays nightly so maybe a recent regression?
(Reporter)

Updated

2 months ago
Crash Signature: mozilla::dom::ChannelWrapperBinding::get_channel
Component: General → DOM
OS: Unspecified → Mac OS X
Product: Firefox → Core
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

2 months ago
Possible dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=1398045 ?
(Reporter)

Comment 2

2 months ago
OK, found a page that triggers this crash on load: https://thegeekygaeilgeoir.wordpress.com/2017/09/06/even-racists-got-the-blues/
Duplicate of this bug: 1398274
(In reply to Robin Whittleton from comment #1)
> Possible dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=1398045 ?

Yeah this looks like a dupe of that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1398045
You need to log in before you can comment on or make changes to this bug.