Crash in mozilla::extensions::detail::ChannelHolder::MaybeChannel

VERIFIED FIXED in Firefox 57

Status

defect
--
critical
VERIFIED FIXED
2 years ago
Last year

People

(Reporter: calixte, Assigned: kmag)

Tracking

(Blocks 1 bug, {crash, regression, topcrash})

57 Branch
mozilla57
Unspecified
Windows 10
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

(Whiteboard: [clouseau], crash signature)

Attachments

(1 attachment)

Reporter

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-fefeaab2-2f80-46b2-97f4-77a470170908.
=============================================================

There are 137 crashes in nightly 57 with buildid 20170907220212. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1396856.

[1] https://hg.mozilla.org/mozilla-central/rev?node=223a7c5a7c471f5fbf319029da2dcc5a093b8548
Flags: needinfo?(kmaglione+bmo)
Reporter

Updated

2 years ago
Crash Signature: [@ mozilla::extensions::detail::ChannelHolder::MaybeChannel] → [@ mozilla::extensions::detail::ChannelHolder::MaybeChannel] [@ mozilla::dom::ChannelWrapperBinding::get_channel]
Reporter

Comment 1

2 years ago
The signature 'mozilla::extensions::detail::ChannelHolder::MaybeChannel' is ranked #4 in top-crashers for browser process.
Keywords: topcrash
Assignee

Updated

2 years ago
Assignee: nobody → kmaglione+bmo
Flags: needinfo?(kmaglione+bmo)
Comment hidden (mozreview-request)

Comment 3

2 years ago
mozreview-review
Comment on attachment 8906006 [details]
Bug 1398045: Correctly handle channels that don't support weak references.

https://reviewboard.mozilla.org/r/177760/#review182832
Attachment #8906006 - Flags: review?(mixedpuppy) → review+
Assignee

Comment 4

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c5047f299f6072182266ef9a9be65cd5d7a9b51b
Bug 1398045: Correctly handle channels that don't support weak references. r=mixedpuppy

Comment 5

2 years ago
Pushed by maglione.k@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c5047f299f60
Correctly handle channels that don't support weak references. r=mixedpuppy

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c5047f299f60
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Duplicate of this bug: 1398042
Duplicate of this bug: 1398274
Good news: this was the #3 Windows topcrash in Nightly 20170908100218, but is absent in Nightly 20170908220146, which is the first build with this fix.
Status: RESOLVED → VERIFIED

Updated

Last year
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.