If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Top Sites "Edit" button disappears after removing all Top Sites

VERIFIED FIXED in Firefox 57

Status

()

Firefox
Activity Streams: Newtab
VERIFIED FIXED
17 days ago
10 days ago

People

(Reporter: cmuresan, Assigned: ursula)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 verified)

Details

Attachments

(1 attachment)

Created attachment 8905850 [details]
Top Sites edit button missing.png

[Affected versions]:
- Firefox 57.0a1 Build ID 20170907220212

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- browser.newtabpage.activity-stream.enabled is set to true in about:config on a clean new profile.

[Steps to reproduce]:
1. Start the browser with the profile from prerequisites and open a new tab.
2. Dismiss all the default Top Sites.
3. Observe the Top Sites section.
 
[Expected results]:
- Empty placeholders are displayed, but the "Edit" button remains.

[Actual results]:
- The "Edit" button disappears along with the last Top Site.

[Notes]:
- The issue is also reproducible if you dismiss Top Sites while you are in the Edit Top Sites menu.
- Attached a screen shot of the issue.

Comment 1

12 days ago
Fixed by https://github.com/mozilla/activity-stream/pull/3461 to be uplifted via bug 1399607.
Blocks: 1399607
Status: NEW → RESOLVED
Last Resolved: 12 days ago
Resolution: --- → FIXED

Updated

11 days ago
status-firefox57: affected → fixed
Target Milestone: --- → Firefox 57

Updated

11 days ago
Assignee: nobody → usarracini
Top Sites "Edit" button is displayed after removing all Top Sites.
Verified as fixed using latest Nightly 57.0a1 Build ID 20170915100121, on Windows 10 x64 and Mac 10.12.
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
You need to log in before you can comment on or make changes to this bug.