Proxy: isn't used for downloading plugins

VERIFIED WORKSFORME

Status

()

Core
Plug-ins
VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: darrell, Assigned: rubydoo123)

Tracking

({helpwanted})

Trunk
x86
Linux
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

Went to the java.sun.com web page.  Mozilla notifies me that there's an applet
on the page, for which I need to download the plugin.  I click OK, it tryes to
connect to the FTP site but cannot because it's not using the defined FTP proxy
server.  If I type the FTP path into the address bar, it connects fine.  It just
doesn't use the proxy while trying to download plugins.

Reproducible: Always
Steps to Reproduce:
1.open a browser that doesn't have the java plugin installed
2.make sure you're behind a proxied firewall
3.make sure you've properly defined the FTP proxy server and port.
4.go to http://java.sun.com
5.click 'OK' to download the plugin
6.watch as it never downloads.  (but only for a moderate amount of time --
otherwise you'll spend the rest of your existence staring at your screen.)

Actual Results:  plugin site isn't contacted

Expected Results:  plugin would be downloaded and installed.

Comment 1

16 years ago
dup of bug 84763?
(Assignee)

Comment 2

16 years ago
looks like it is a dupe

*** This bug has been marked as a duplicate of 84763 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
Not a dupe. The other bug is about the stub installer, which has its own
networking code, UI, etc. This is about the browser using Necko to download a
file via FTP through a proxy.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

16 years ago
so reassign to n/w-king?
(Assignee)

Comment 5

16 years ago
so Syd, why not assign it to the correct group then? Reassigning
Assignee: beppe → new-network-bugs
Component: Plug-ins → Networking
QA Contact: shrir → benc

Comment 6

16 years ago
+helpwanted, problem definition is clear w/ updated summary.

I don't know who owns the code that should do this.
Keywords: helpwanted
Summary: proxy isn't used for downloading plugins → Proxy: isn't used for downloading plugins
...who knows that?

Comment 8

16 years ago
-> Plugins.

This bug is kind of old, lets see if they have been having this problem (since
it is likely to be a standard test case they have.)
Assignee: new-network-bugs → beppe
Component: Networking → Plug-ins
QA Contact: benc → shrir
(Reporter)

Comment 9

16 years ago
Hello -- This is now working on 1.1 Beta! 
 
Thanks! 
also a way to solve it ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 11

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.