Need ability to remove new sidebar icon from the personal toolbar

VERIFIED FIXED

Status

SeaMonkey
Preferences
VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: Scott MacGregor, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
using build ID: 2002042403

Just like the rest of the buttons we add to the personal toolbar (app
components, search buttons, etc.) we need a checkbox in prefs under: 
-> Navigator
  --> Select the options you wish to see in the toolbars:
    
There should be a new checkbox here for the sidebar button.

Also, if I hit F9 to get rid of the sidebar shouldn't we hide this new button as
well since it means I don't want to be losing any real-estate to the sidebar. If
I want it back, I'll hit F9 again. I guess that bypasses the goal of making it
easy to bring it back though.....

Comment 1

16 years ago
Component --> Preferences. All/all.

The other issue you mention is bug 139691, methinks.
Component: Sidebar → Preferences
Keywords: mozilla1.0
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

16 years ago
I see one in build 2002042422 trunk

Comment 3

16 years ago
*** Bug 139961 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
One a further note, the pref works but does not survive a restart.
(Assignee)

Comment 5

16 years ago
The missing file has been checked in.  The pref will work.  The personal toolbar
code has a flaw in that it requires buttons that don't show by default to be
initialized in all.js to false and to be hidden in the default localstore.rdf. 
But this doesn't fix the problem for profiles that already exist before the
feature lands.  

So special handling will need to be done in the sidebar code to detect if the
sidebar button has no hidden attribute and then set it according the pref value.
 Alternatively, jag and I chatted about fixing the personal toolbar code but his
experience was last time they tried to do that the fallout of problems was not
worth it.

At any rate, that additional code will be a part of bug 134345 which is tracking
whether this feature remains in or is backed out.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 6

16 years ago
Sounds more like "fixed" (or maybe "worksforme") than "invalid" to me.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 7

16 years ago
Creating a new profile in 2002042403 (0.9.9+) trunk Windows 98, does not result
in a setting in Preferences to turn this off. This supports reopening the bug.
yes, i see this in the Navigator panel of a new profile i created using
2002.04.25.08-gmake (trunk) comm bits on win2k.

re-marking fixed.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 9

16 years ago
After creating a new profile with Build ID: 2002042510, trunk, the icon is
showing but the preference is unchecked. 

Check the preference, close preferences, icon still showing. Open preferences,
uncheck, close prefs, icon not showing.

Now that icon is not showing, open a new window. Icon shows on new window. 

Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

16 years ago
Feature backed out.  
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
Depends on: 134345

Comment 11

16 years ago
verified in 4/29 build.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.