Private browsing icon missing from private windows on Nightly

VERIFIED FIXED in Firefox 57

Status

()

defect
--
major
VERIFIED FIXED
2 years ago
Last year

People

(Reporter: haik, Assigned: Gijs)

Tracking

({regression})

57 Branch
Firefox 57
Points:
---
Dependency tree / graph
Bug Flags:
in-qa-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 verified)

Details

Attachments

(3 attachments)

On OS X, the private browsing icon is missing from the top-right of the title bar on today's Nightly.

mozregression:

 5:39.23 INFO: No more inbound revisions, bisection finished.
 5:39.23 INFO: Last good revision: 481d7cc2f6f06ea35794403dc9291d277910d6b9
 5:39.23 INFO: First bad revision: 1fae43b4534cf25d917e544ca02e7ad6b1aa1736
 5:39.23 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=481d7cc2f6f06ea35794403dc9291d277910d6b9&tochange=1fae43b4534cf25d917e544ca02e7ad6b1aa1736

Which is bug 1397236 - "Changing positioning of navigator-toolbox while a descendent popup is open causes the popup to close. We don't need to change the positioning of the navigator-toolbox on the fly, and can instead always keep it as position:relative for the library animation."
Blocks: 1397236
Flags: needinfo?(jaws)
Keywords: regression
Drew, do you think you could help take a look at this since I'm going to be away for the next two days?
Flags: needinfo?(jaws) → needinfo?(adw)
I saw bugmail for this and figured it out pretty quickly, so I wrote a patch.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(adw)
(In reply to Haik Aftandilian [:haik] from comment #0)
> On OS X, ...

and on Windows.

Gijs, your patch doesn't seem to fix this regression on windows?
(In reply to Ekanan Ketunuti from comment #4)
> (In reply to Haik Aftandilian [:haik] from comment #0)
> > On OS X, ...
> 
> and on Windows.
> 
> Gijs, your patch doesn't seem to fix this regression on windows?

No, because nobody said that there was an issue on Windows until you did, and the element in question is osx-specific ( https://dxr.mozilla.org/mozilla-central/source/browser/base/content/browser.xul#605-610 ), and Jared normally works on Windows, so it seemed logical to assume the issue was restricted to OS X.

I'll check Windows and see what's the matter there.
OS: Unspecified → All
Hardware: Unspecified → All
I actually can't reproduce this on windows 10 with the Sept. 10 nightly, no matter whether the title bar is on/off, whether I'm using normal, touch or compact, density, or a lightweight theme or the default theme. Can you clarify where you're seeing this on Windows?
Flags: needinfo?(ananuti)
(In reply to :Gijs from comment #6)
> I actually can't reproduce this on windows 10 with the Sept. 10 nightly, no
> matter whether the title bar is on/off, whether I'm using normal, touch or
> compact, density, or a lightweight theme or the default theme. Can you
> clarify where you're seeing this on Windows?

Hmm, interesting. It looks like I can reproduce only with dark theme. just enable dark theme and press Ctrl-Shift-P.
Flags: needinfo?(ananuti)
(In reply to Ekanan Ketunuti from comment #7)
> Hmm, interesting. It looks like I can reproduce only with dark theme.

I cannot reproduce with Default theme but Dark and Light theme.
Oh, pressing Alt button and I found PB icon is on munubar.
Duplicate of this bug: 1398746
FWIW, I checked, and I don't think this happens on Linux because we don't have tabsintitlebar there at all.
Comment on attachment 8906559 [details]
Bug 1398264 - position private browsing indicator and/or 10.9 fullscreen button to cope with the background on the toolbox,

https://reviewboard.mozilla.org/r/178308/#review183394

Thanks
Attachment #8906559 - Flags: review?(adw) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/cbd4482d8d2e
position private browsing indicator and/or 10.9 fullscreen button to cope with the background on the toolbox, r=adw
https://hg.mozilla.org/mozilla-central/rev/cbd4482d8d2e
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Duplicate of this bug: 1399088
I have reproduced this bug with Nightly 57.0a1 (2017-09-08) on Windows 10 , 64 Bit ! 

This bug's fix is Verified with latest Beta !

Build   ID    20171005195903
User Agent    Mozilla/5.0 (Windows NT 10.0; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0
QA Whiteboard: [bugday-20171004]
Status: RESOLVED → VERIFIED
Flags: in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.