Local Storage not cleared by Clear Recent History

VERIFIED DUPLICATE of bug 1047098

Status

()

Core
DOM
--
critical
VERIFIED DUPLICATE of bug 1047098
3 months ago
a month ago

People

(Reporter: m517012, Unassigned, NeedInfo)

Tracking

(Blocks: 1 bug, {privacy, regression, regressionwindow-wanted})

55 Branch
privacy, regression, regressionwindow-wanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 wontfix, firefox56 fixed, firefox57 verified)

Details

(Whiteboard: [tor][fingerprinting])

(Reporter)

Description

3 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170824123605

Steps to reproduce:

1. Go to weather.com
2. Add some random location through their add locations feature.
3. Close tab with weather.com
4. Use the clear recent history feature to clear time range of everything and all items.
5. Go to weather.com again and wait a little bit.


Actual results:

The location you added appears.
Open Developer Tools, Storage and look under Local Storage for weather.com, which will have jStorage key with your saved location.


Expected results:

Local Storage should have been cleared
(Reporter)

Comment 1

3 months ago
Forgot to mention this is with a new profile.

Updated

3 months ago
Component: Untriaged → Bookmarks & History
Appears to be a duplicate of bug 527667
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 527667
Reopening per bug #527667 comment 43
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
See Also: → bug 1400582
Severity: normal → critical
Status: REOPENED → NEW
Has Regression Range: --- → no
Has STR: --- → yes
Keywords: privacy, regression, regressionwindow-wanted
Blocks: 1329996
Whiteboard: [tor][fingerprinting]
Component: Bookmarks & History → DOM
Product: Firefox → Core

Comment 4

3 months ago
(In reply to m517012 from comment #0)
> 1. Go to weather.com
> 2. Add some random location through their add locations feature.
> 3. Close tab with weather.com
> 4. Use the clear recent history feature to clear time range of everything
> and all items.

Now look at webappsstore.sqlite and it should be empty

> 5. Go to weather.com again and wait a little bit.

Data is being respawned (from indexedDB i think)
Mark, same question as https://bugzilla.mozilla.org/show_bug.cgi?id=1400582#c4
Flags: needinfo?(mliang)

Comment 6

3 months ago
I did a regression range and here are the results: 
Last good revision: 50a06f21ea6c08bd137fcff0eabda9527d4b3b38
First bad revision: 6256be938d185fca64a28f3f4ce4ffcfb2ee1f6d
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=50a06f21ea6c08bd137fcff0eabda9527d4b3b38&tochange=6256be938d185fca64a28f3f4ce4ffcfb2ee1f6d
Blocks: 1370491
status-firefox55: --- → unaffected
status-firefox56: --- → affected
status-firefox57: --- → affected
I performed various tests in Firefox 55.0.3 and I can confirm the following:

Using the "Clear Recent History" dialog with the "Offline Website Data" option successfully clears:

- Cookies
- Local Storage

It fails to clear:

- Indexed DB

Firefox 55 is clearly affected and this bug is not actually about Local Storage, but about Indexed DB.
status-firefox55: unaffected → affected
Just verified that Firefox 57 is affected, too.

STR:
- Create fresh profile
- Go to http://cr.23bit.net/idb.html
- Acknowledge database update and reload a few times to accumulate visit timestamps
- Open Storage Inspector (Shift-F9)
- Select website under Cookies and click "+" (below "Debugger") to add a few random cookies
- Select website under Local Storage and click "+" to add some random data
- Select "History / Clear Recent History" from Menu (Ctrl-Shift-Del on Windows)
- Choose time range "Everything" and ensure that everything under "Details" is ticked, including "Offline Website Data"
- Re-open Storage Inspector to update its data

Expected result:
- Data under Cookies, Indexed DB and Local Storage is gone.
- Reloaded website forgets about previous visits.

Actual result:
- Visit data under Indexed DB persists
- Reloaded website remembers previous visits.
This is a duplicate of bug 1047098. Let's move discussion there.
Status: NEW → RESOLVED
Last Resolved: 3 months ago3 months ago
Resolution: --- → DUPLICATE
See Also: → bug 1047098
Duplicate of bug: 1047098

Comment 10

3 months ago
Does this mean bug 1047098 covers Local Storage as well? Perhaps its summary should be changed to accurately reflect what it's about. See also bug 1367607.
(In reply to bintoro from comment #10)
> Does this mean bug 1047098 covers Local Storage as well?

So far the testing revealed that Local Storage is cleared in both 55 and 57, so AFAICS there is no reproducible bug regarding Local Storage. The only odd behavior around Local Storage I can reproduce in 57 is that `Offline Website Data` requires to be combined with `Cookies` to actually wipe Local Storage. That bit is captured in bug 1047098.
status-firefox55: affected → wontfix
status-firefox56: affected → fixed
status-firefox57: affected → fixed
I verified this issue using Firefox Beta 57.0b14 with Build ID 20171102100122 on Windows 10 x64, Windows 7 x32, Ubuntu 16.04.
I will mark this as verified fixed.
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
You need to log in before you can comment on or make changes to this bug.