Closed Bug 1398326 Opened 2 years ago Closed 2 years ago

Permissions prompts don't show default extension icon

Categories

(WebExtensions :: Android, defect)

53 Branch
defect
Not set

Tracking

(firefox57 verified)

VERIFIED FIXED
mozilla57
Tracking Status
firefox57 --- verified

People

(Reporter: aswan, Assigned: aswan)

References

Details

Attachments

(2 files)

I though I had tested my last-minute changes to bug 1379833 to fix android lint failures but I apparently I didn't and the browser crashes when trying to display a permissions prompt with the generic extension icon.
Assignee: nobody → aswan
Attachment #8906102 - Flags: review?(walkingice0204)
Comment on attachment 8906102 [details]
Bug 1398326 Fix display of default extension icon in permission prompts

https://reviewboard.mozilla.org/r/177840/#review183108
Attachment #8906102 - Flags: review?(walkingice0204) → review+
Duplicate of this bug: 1398831
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/27cf5225d7e0
Fix display of default extension icon in permission prompts r=walkingice
https://hg.mozilla.org/mozilla-central/rev/27cf5225d7e0
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Attached image PNGformat.png
This issue is verified as fixed on Fennec 57.0a1 (2017-09-13)  under Android 6.0.1.

The default extension icon that uses a PNG format is displayed in the permission pop-up.
Extension used for testing:https://addons-dev.allizom.org/en-US/firefox/addon/beastify-for-android/?src=search 

Please see the attached screenshot.
Status: RESOLVED → VERIFIED
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.