On a localized build, unable to copy mails to Sent folder when sending out from a POP account after selecting the account that holds the Sent folder

VERIFIED FIXED

Status

MailNews Core
Internationalization
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: ji, Assigned: Navin Gupta)

Tracking

({intl})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt1])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
Build: 04/19 Ja build.

This is a very strange problem. 
On above Ja build, default mail folder names are translated to Japanese. So on
account manager-> Copies and Folders pane. Sent folder is also translated. With
this, everytime when I send out mails from a POP account, I get an error msg
saying that it can't copy mails to Sent folder. And I don't have this problem
when connecting to the server the 1st time. But after exiting the program and
reconnecting the server the 2nd time, I start to have this problem. When I get
this error msg, I can see on the folder pane there is an extra folder generated
with another set of default folders as its children folders. 

Steps to reproduce:
1. Create a new profile with the Ja build.
2. Set up a POP mail account with the new profile.
3. After login window comes up, login with correct passwd,  send out a mail, so
far, no problem.
4. Exit the program, restart, and bring up Mail window.
5. After connecting to the server, compose a mail and click on Send
   Then an error msg comes up, saying that the mail is sent successfully, but it
can't copy mail to the Sent folder. Observe the folder pane, there is extra
folder created, the parent folder name is blank, but with another set of default
folders as its child folders. I'll attach a screenshot.
6. Open Edit | Mail and News Account Settings | Copies and Folders pane, change
the folder which holds sent copies to a different one, then I can sent out mail.
7. Open Explorer, go to the profile -> Mail folder, besides "Local Folders" and
POP mail account, there is extra msf file generated.
(Reporter)

Comment 1

16 years ago
Created attachment 80820 [details]
A screenshot.
(Reporter)

Comment 2

16 years ago
Nominating for nsbeta1, since the user will get this error message when sending
out mails if he/she doesn't change the sent folder location, and also the extra
folder displayed on the folder pane is very confusing.
Keywords: intl, nsbeta1

Comment 3

16 years ago
Cc to putterman.
Scott, I would like someone in your group to work on this. I think localizable
folder name for Pop is a new feature. Who implement that?
(Assignee)

Comment 4

16 years ago
taking
Assignee: nhotta → naving

Comment 5

16 years ago
i hit the same problem yesterday with the POP account on the new ja build (based
on 04-19 branch)
(Assignee)

Comment 6

16 years ago
Are you using Quick launch/turbo, curious because it is happening on 2nd time
(Reporter)

Comment 7

16 years ago
No, I installed the build with turbo turned off.
(Reporter)

Comment 8

16 years ago
Created attachment 80837 [details]
A screenshot of Copies and Folders pane of account manager

Additional info:
On Copies and Folders pane, for sent folder selection, if I choose "Others" and
select localized Sent folder from there, it can copy the mail to Sent folder.
So it looks like it can't map the localized Sent folder name from the localized
string, which is the list box label of the first option for Sent folder
location, to the English mailbox name.

The reason that it didn't fail the 1st time could be that it didn't go through
this path: getting Sent folder name from the localized list box label and
mapping to English foldername which is really generated in the profile.
(Assignee)

Comment 9

16 years ago
what does your user_pref mail.identity.id1.fcc_folder look like in prefs.js? It
should be something like "mailbox://3qatest03@nsmail-2/Sent"

Comment 10

16 years ago
impact language users- all European and Asian internet users who use mail. (329M
users or 51.8% of total internet users)
Visibility- HIGH- major functionality
Recover after hitting the problem- 
Work around- set the copy folder manually inside the account setup.

this is a [adt1] bug, all the users using POP3 mail on localized build will see
this issue several times a day. 
Whiteboard: [adt1]

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1+
(Reporter)

Comment 11

16 years ago
Created attachment 80886 [details]
my prefs.js file.
(Reporter)

Comment 12

16 years ago
Save as Draft or Template has the same problem.
(Assignee)

Comment 13

16 years ago
yes, your prefs are messed up 

user_pref("mail.identity.id1.fcc_folder", "mailbox://ji2@polyglot.mcom.com/áÈì¤");

should be 

user_pref("mail.identity.id1.fcc_folder", "mailbox://ji2@polyglot.mcom.com/Sent");

So when you send mail first time ? can you verify what this prefs looks like. 
I may need a localized debug build to debug this.

Comment 14

16 years ago
You can use your US debug build, plus the JA language pack.
ftp://sweetlou/products/client/l10n_dev/seamonkey/ja/win/2002-04-19-08-1.0.0/xp
i/
(Reporter)

Comment 15

16 years ago
I played more with the build, it looks like it has nothing to do with the passwd
dialog.
And it has nothing to do with when it's connected to the server either. To
reproduce the problem, you just need to go to Copies and Folders pane, reselect
the account following the translated list box label which contains translated
Sent folder name.
It also happens when you change the account to Local Folders on the list. It
seems selecting the account writes the translated folder name to the pref.
Summary: On a localized build, unable to copy mails to Sent folder when sending out from a POP account after the 2nd connection to the server → On a localized build, unable to copy mails to Sent folder when sending out from a POP account after selecting the account that holds the Sent folder
(Assignee)

Comment 16

16 years ago
Created attachment 81176 [details] [diff] [review]
proposed fix

The fix is to use the internal names and not the prettyName when we are again
writing the Sent, Drafts.. folder settings as prefs. We always use internal
names
for folderURIs, prettyName is just used for display.
(Assignee)

Comment 17

16 years ago
ji, thanks for looking into what was causing the bug. This affects all builds.
although on US builds we are able to create a new sent folder because uri is
(ascii -utf8 format) but for localized builds it becomes a problem. 

bhuvan, can I get an r=? thx.
Status: NEW → ASSIGNED
I think gMessengerBundle is now unused.  Can you confirm, and if so, remove it 
from the js and xul (I think you can remove the "bundle_messenger" element)

 

Comment 19

16 years ago
Comment on attachment 81176 [details] [diff] [review]
proposed fix

yeah, removed unused vars. please do make sure that it is not being used in any
other places via some looped dependency.

r=bhuvan
Attachment #81176 - Flags: review+
(Assignee)

Comment 20

16 years ago
Created attachment 81209 [details] [diff] [review]
patch removing unused global vars.
Attachment #81176 - Attachment is obsolete: true
(Assignee)

Comment 21

16 years ago
Comment on attachment 81209 [details] [diff] [review]
patch removing unused global vars. 

carrying fwd bhuvan's 
review
Attachment #81209 - Flags: review+
Comment on attachment 81209 [details] [diff] [review]
patch removing unused global vars. 

sr=sspitzer

but make extra sure that your changes don't cause any problems, mozilla or ns. 
the change to AccountWizard.xul, especially.
Attachment #81209 - Flags: superreview+

Comment 23

16 years ago
Can you not checkin the AccountWizard changes now (I will file a new bug to
remove all unused vars in mailnews) ? We have bunch of overlays, which rely on
this file from ns side. We don't want any unexpected regressions from there at
this point of time. I only meant that you should take them out of am-copies.xul
 as that looks pretty self-contained. Don't need a new patch, just get
am-copies.* changes in.
(Assignee)

Comment 24

16 years ago
checked in am-copies.js and am-copies.xul changed on trunk. 
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 25

16 years ago
Can someone try this fix out on the trunk?  Navin, what else needs to be tested
because of this fix?
Keywords: adt1.0.0
(Assignee)

Comment 26

16 years ago
The changes affect only copies and folders panel in account manager. 

Comment 27

16 years ago
Adding adt1.0.0+.  Please check this into the branch as soon as possible after
getting drivers approval and add the fixed1.0.0 keyword.
Keywords: adt1.0.0 → adt1.0.0+
(Reporter)

Comment 28

16 years ago
Ying or Ray, how can I replace am-copies.js and am-copies.xul in ja build with
those checked in by Navin so i can verify the fix before the next ja build?
Or what should I do on an English trunk build to get a pseudo localized account
manager | copies and folders pane?

Updated

16 years ago
Attachment #81209 - Flags: approval+
Comment on attachment 81209 [details] [diff] [review]
patch removing unused global vars. 

a=rjesup@wgate.com for branch checkin
(Reporter)

Comment 30

16 years ago
Verfied as fixed on a ja build with the new messenger.jar that contains Navin's
am-copies.js and am-copies.xul. Thanks Ying for the help.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

16 years ago
Keywords: fixed1.0.0
(Reporter)

Comment 31

16 years ago
Verified as fixed with Ja build.
Keywords: fixed1.0.0 → verified1.0.0
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.