Crash in RequestContext::Notify() in debug builds on tuner.cloud

RESOLVED DUPLICATE of bug 1395884

Status

()

Core
Networking: HTTP
--
critical
RESOLVED DUPLICATE of bug 1395884
3 months ago
2 months ago

People

(Reporter: jesup, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fe:investigate], URL)

(Reporter)

Description

3 months ago
+++ This bug was initially created as a clone of Bug #1385531 +++

Opened https://tuner.cloud
Before answering the device access request, the browser crashes in a Debug build with a MOZ_ASSERT in the TimeStamp code (comparing a timestamp that isn't set).

Stack: 
#0  0x00007fffe0243fa8 in mozilla::TimeStamp::operator>(mozilla::TimeStamp const&) const (this=0x7fffb9acdc68, aOther=...) at ../../dist/include/mozilla/TimeStamp.h:568
#1  0x00007fffe031f577 in mozilla::net::RequestContext::Notify(nsITimer*) (this=0x7fffb9acdc00, timer=0x7fff94cfb820) at /home/jesup/src/mozilla/inbound/netwerk/base/RequestContextService.cpp:313
#2  0x00007fffe026bc7b in nsTimerImpl::Fire(int) (this=0x7fff94d11600, aGeneration=1)
    at /home/jesup/src/mozilla/inbound/xpcom/threads/nsTimerImpl.cpp:517

in Frame 1, mUntailAt has a value of 0 (unset).
(Reporter)

Comment 1

3 months ago
Florian - an you loop in whomever should be looking at this?  Thanks
Flags: needinfo?(florian)
Whiteboard: [fe:investigate]
Assuming the code a month ago was similar to the current RequestContext::Notify code at http://searchfox.org/mozilla-central/rev/1033bfa26f6d42c1ef48621909f04e734a7ed8a3/netwerk/base/RequestContextService.cpp#315 this is an assertion added in bug 1358060. Moving to bug 1358060's component.
Component: Device Permissions → Networking: HTTP
Flags: needinfo?(florian)
Product: Firefox → Core
Blocks: 1358060
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1395884
You need to log in before you can comment on or make changes to this bug.