bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Send Link gone from context menu

VERIFIED DUPLICATE of bug 137007

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 137007
17 years ago
7 years ago

People

(Reporter: brendan, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I didn't read the spec in time.  But I used to Send Link all the time (in bugs,
especially).  Blake says I'm not a typical user.  Who is?  We have seen zero
usability study data on this issue.

Now I cannot right-click on a link and send it.  I have to load the linked-to
page (which is undesirable because slow and because of potential side-effects),
then use File > Send Link; or else right-click, Copy Link Location, and paste
that into a new message.

This is a pure regression.  There is no efficient, side-effect free emulation. 
It shouldn't have happened during the 1.0 milestone cycle.  I say it needs to be
fixed, just as other mistakes such as the File > Send > {Link, Page} flyout were
undone at the eleventh hour.

/be
(Reporter)

Updated

17 years ago
Keywords: mozilla1.0
WONTFIX.

staff@mozilla.org have said that the module owner gets to decide what goes in.
The module owner has said that we should follow the spec. The spec is clear
about where the menu items in question appear. The author of the spec has
explained his position (in the original bug for context menus) and is unlikely
to change his opinion since no new arguments have come to light. The module
owner has no reason to not trust the UI designer. Therefore the only way you are
likely to see this changed in Mozilla builds is to get staff@mozilla.org to
change the module owner to someone who agrees with you.

I suggest you ask your Mozilla distributor (if you use RedHat, Beonex, Netscape,
etc) or embedder (if you use OEOne, Galeon, Chimera, etc) to change the context
menu in their release. Failing that, you could always start your own
distribution or embedding project whose target audience expects to be able to
use the "Back" menu item in all context menus.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
er. s/Back/Send Link/ on the last line of my comment.

Comment 3

16 years ago
Reopening to mark as a dup of bug 137007.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 137007 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE
VERIFIED DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.