Configuration Warnings during startup

RESOLVED DUPLICATE of bug 193638

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 193638
15 years ago
8 years ago

People

(Reporter: Steven Bush, Assigned: Matti)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
With the most recent build that I downloaded (w32-talkback, build id:
2002042403), I receive two dialog boxes reporting configuration warnings during
the startup of the browser.  They both appear immediately after the splash
screen appears when attempting to execute mozilla.exe after extracting all the
files from the w32-talkback.zip file and overwriting my previous version (which
I believe was 20020401xx)

The first error reports:
An error occurred reading the startup configuration file.  Please contact your
administrator.  line 47: Reference Error: defaultPref is not defined

Second error is very similar:
An error occurred reading the startup configuration file.  Please contact your
administrator.  line 47: Reference Error: config is not defined

To my knowledge, I have not touched my configuration file in a very long time.
(Assignee)

Comment 1

15 years ago
Reporter:
Can you please try this :
Uninstall mozilla, delete all files that are not deleted by the uninstaller in
c:\programs\mozilla.org (but save your plugins) and reinstall mozilla
(Reporter)

Comment 2

15 years ago
Okay... I didn't reinstall, but I did the following and the warnings stopped:

1. Went into /defaults/pref
2. created a folder called "old"
3. moved the files "config.js" and "initpref.js" into that folder.

everything seems okay now...

"config.js" had the following information (after a lengthy license block):

config("startup.homepage_override_url","chrome://navigator-region/locale/region.properties");
config("autoadmin.append_emailaddr",false);
config("autoadmin.failover_to_cached",true);

config("browser.chromeURL","chrome://navigator/content/navigator.xul");


"initpref.js" had the following information that I believe was causing the
difficulty (there was other information as well:
// --- Preference initialization functions ---
//
//    Moved to native functions:
//    pref        -> pref_NativeDefaultPref
//    defaultPref -> ""
//    userPref    -> pref_NativeUserPref
//    lockPref    -> pref_NativeLockPref
//    unlockPref  -> pref_NativeUnlockPref
//    getPref     -> pref_NativeGetPref
//    config      -> pref_NativeDefaultPref   (?)

// stubs for compatibility
var default_pref = defaultPref;
var userPref = user_pref;

(Assignee)

Comment 3

15 years ago
wfm -> corrupted prefs file
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 4

14 years ago
.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Assignee)

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 193638 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Blocks: 193638
You need to log in before you can comment on or make changes to this bug.