Duplicate messages in thread view after 'Mark all read'

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Mikhail Sogrine, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla 1.0rc1 build 2002041711, Win2K, modern skin.

Reproducible: for some newsgroups. If reproducible for one thread in a
newsgroup, then it seems to reproducible for all other threads in the same
newsgroup, and vice versa.

Steps:
1. Switch to the news folder.
2. Choose a thread (with more than one message).
3. Mark first message of the thread as unread -> subject becomes bold.
4. Expand thread -> thread triangle points down.
5. Mark all messages read (by key shortcut or by menu item)
      Expected result: thread is still expanded and thread triangle still points
down
      Actual result: thread is expanded (visually) BUT thread triangle points RIGHT
6. Click on thread triangle
      Expected result: collapse the thread
      Actual result: second copy of the thread (all messages expect the first
one) appears just after the first message and before the rest of the messages
(you can see where selection goes if expanding and collapsing again) with
correct hierarchy linking.

Steps 3 and 4 may be done in any order.
Steps 3-6 can be repeated to get even more copies of the thread (I got 4 copies
and it doesn't seem to show any changes).

It seems that in this situation, thread is marked as collapsed (see thread
triangle) but list items are not removed and Mozilla continue to show them to
user.

And other comments:
- All messages in all copies are clickable and show correct text below; subjects
pane is scrollable if you have enough messages.
- Going to another folder and returning back resets situation.
- It does not depend on current View/Messages setting, it is only needed to be
one of threaded views.

This bug is somehow connected to 123858, but it is not equivalent to it. Result
is the same, steps to reproduce are different.

Updated

16 years ago
QA Contact: olgam → laurel

Comment 1

16 years ago
That's really weird. Can you reproduce this on a recent nightly build? You can
get one from www.mozillazine.org.

Nice bug report, by the way!

-M
(Reporter)

Comment 2

16 years ago
OK, now it seems to work fine, I have a different computer with WinXP.
And even before the bug was happening not in all newsgroups. It is possible that
bug is still there or it is fixed with some other bug.

So currently I resolve the bug as WORKSFORME, will reopen if will see it again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 3

16 years ago
marking verified worksforme.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.