Thunderbird 56.0b3 crashing repeatedly when open 1st unread mail.

RESOLVED DUPLICATE of bug 1368786

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 1368786
11 months ago
10 months ago

People

(Reporter: doug2, Unassigned)

Tracking

56 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36

Steps to reproduce:

56.0b3 running in Win10 64 bit.  Open 1st unread mail. View message for 1-2 secs, then crash.  8 crashes today.  No add ons.  Not in Safe Mode. Crash reporter shows crashes, says submitted.  1k data.  Running POP client.


Actual results:

Crash and restart


Expected results:

Not crash, read mail

Comment 1

11 months ago
Can you please post the crash IDs here, you'll find them in "Help > Troubleshooting Information".

Wayne, this one is for you ;-)
Flags: needinfo?(vseerror)
(Reporter)

Comment 2

11 months ago
Created attachment 8906308 [details]
TBirdCrashIDs.JPG   screen shot of the latest crashes.

Comment 4

11 months ago
Thanks the crash is at morkRow.cpp:516 which makes it a duplicate of bug 1368786. We've been tearing our hair out to find a reproducible case. Maybe you would consider making your e-mail data (or a subset that will reproduce the crash) available to us.

Can you identify a crashing message or a crashing folder?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1368786
(Reporter)

Comment 5

11 months ago
Always in Inbox, reading 1st unread message. Does not happen every time. Open unread, message window appears on screen (not tab), 1-2 seconds, crash. Message is marked read when TBird restarts. Then read same message, go on to other mail, no problem - usually.  (Has happened twice in succession if I pick the new oldest unread to open instead of the last read message.)
I just tried marking a number of messages as unread and then opening them one at a time. No problem.  I shut down TBird and restarted in safe mode and tried again.  No problem.  So, I can't reproduce it.
Currently have 17 pieces of read mail in InBox, which has been about typical.
Do messages read and then marked unread have different attributes than initially unread?

What final process takes place as the message is displayed in a window. Something that would crash not just the window, but TBird?  Some kind of linking or garbage collection or prep for whatever comes next or final display steps in the window (e.g., menu items, updating the unread count in the main window)?
Got a new piece of mail, tried opening it.  No problem.  
As far as I know, it has never been the same piece of mail or sender for two crashes. Always in Inbox (main identity).  
Let me know if you can think of some scenario to try.

Comment 6

11 months ago
Reporter, would you be willing to test a Daily version? If so, do you think that the crash is happening frequently enough for you that if you can't get that Daily version to crash, we can assume that the problem is indeed solved?

Updated

11 months ago
Flags: needinfo?(vseerror)
(Reporter)

Comment 7

11 months ago
Thought I replied?  
Yes, just tell me how to download a daily.  
I can't make it happen.  It crashed 8 times yesterday and 3 times the day before but has not crashed today.  
Agree that it feels like uninitalized data or bad pointer.  Doesn't feel like race condition or other timing issue.

Comment 8

11 months ago
Yes, you replied in comment #5, but I had more questions in comment #6. We know that the problem can't be produced at will, but I analysed it further and you can read my analysis in bug 1368786 comment #17.

I'll compile you a special Daily version. In two hours you can download it from here:
https://archive.mozilla.org/pub/thunderbird/try-builds/mozilla@jorgk.com-251de43c5bb9289064b0fa572eae43f1a98a48ff/
Hmm, just noticing that the compile process hasn't started yet, so there might be a technical problem, so please don't hold your breath. I'll check it tomorrow.

Comment 9

11 months ago
OK, I finally managed to compile that version. Download from here:
https://archive.mozilla.org/pub/thunderbird/try-builds/mozilla@jorgk.com-fdef068681bf1d003de42afe5b581237f3fe3f74/try-comm-central-win32/thunderbird-57.0a1.en-US.win32.installer.exe

You can install this in parallel to your existing beta version. Please let me know if this fixes the crashes.

Note, this is a Daily version and sadly due to bug 1398579 is doesn't allow you to drag messages between folders. That bug is almost fixed, so if that's an impediment, I can get you a totally working version.
(Reporter)

Comment 11

10 months ago
Ran the first one for a few hours. Now running the 2nd.  Will report any crashes here.

Comment 12

10 months ago
Thanks, first and second one behave the same re. the crashes, only that the second one lets you drag messages again.

Comment 13

10 months ago
It would be great if you could let me know by the end of Tuesday, tomorrow, whether you think that this version solves the problem.
(Reporter)

Comment 14

10 months ago
Have read about 30 new messages from InBox plus 30-40 more in a filter-managed folder. No crashes so far.
BTW, I've had problems for years on two different machines and several versions of Windows and TBird with unread mail windows disappearing after I opened them, but the mail marked read and no crash.  I reported/joined s a bug that should be somewhere in my list.  My conjecture is that it was a previous instance of this bug, but the new code "fixed" it and then caused the crash.

Comment 15

10 months ago
Let's wait until Tuesday for a verdict, but thanks for the update, it's looking promising.

As for the bug you mentioned, you're talking about bug 711204? Here's your list:
https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&emailtype1=exact&emailreporter1=1&email1=dmccammishjr%40gmail.com&list_id=13772035
(Reporter)

Comment 16

10 months ago
Yes  big #711204 is the old problem.
(Reporter)

Comment 17

10 months ago
So far, 2 possible issues. (1) One or two occurrences of the old problem 711204 new message window opens and then closes immediately. (2) (minor) the new mail icon does not appear consistently when there is new mail. (The icon appearance has been inconsistent for a long time, but in the other direction - 2 icons or the icon does not go away when all mail is read).  I'm going to watch and test #1 today as much as I can. Even so, these are better than crashes.

Comment 18

10 months ago
I didn't promise to fix all problems you have with TB, only the crashes ;-) Thanks for your reports so far, maybe a final report tonight since we'll assess the patch you've been testing tomorrow.
(Reporter)

Comment 19

10 months ago
Still no crashes on this daily.  Definite regression on old problem 711204, however. New message window disappears (crashes?), message marked read.
You need to log in before you can comment on or make changes to this bug.