Changing folder properties to japanese-ISO-2022/or to UTF8 turns nomime headres blank/freeze on scrolling

VERIFIED FIXED in mozilla1.0

Status

MailNews Core
Internationalization
--
major
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: marina, Assigned: Roy Yokoyama)

Tracking

({hang, intl})

Trunk
mozilla1.0
x86
Windows 2000
hang, intl

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt1] [ETA 05/03])

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
*** observed with 2002-04-23 branch build and localized ja build***
This bug happens somehow only with iso-2022 (i tried other ja and chinese
encodings and they are fine). This is especially visible for localized builds
where the default encoding is iso-2022. 
Steps to reproduce:
-add news.mcom.com ;
-subscribe to a russian newsgroup (say kherson.commerce, this one i just know is
huge and has mostly no-mime headers;)
- download all messages;
- you'll see the headers displayed blank;
- try to scroll, you'll crash
PS. i don't crash when i scroll in the folder with 10-15 messages, this
newsgroup has~ 500

Comment 1

16 years ago
Please attach talkback info.
Status: NEW → ASSIGNED
Keywords: crash, nsbeta1
(Reporter)

Comment 2

16 years ago
actually i have to reframe my comments: the application gets frozen, doesn't
crash so no talkback..
Summary: Changing folder properties to japanese-ISO-2022 turns nomime headres blank/scrolling crash → Changing folder properties to japanese-ISO-2022 turns nomime headres blank/freeze on scrolling

Updated

16 years ago
Keywords: crash → hang

Comment 3

16 years ago
impact language users: all japanese users 52.1M 9.2% of internet users
visibility- HIGH, in major functional area- we will freeze in mail OR news
severity- HIGH, hang when we hit that problem 

this is a [adt1] bug. 

roy- please help to figure out why we are hang here. nhotta is busy for other
adt1 bug now. 
Assignee: nhotta → yokoyama
Status: ASSIGNED → NEW
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt1]
(Assignee)

Comment 4

16 years ago
Let's see what I can do.
Target Milestone: --- → mozilla1.0

Comment 5

16 years ago
There is another bug (bug 134694) filed for the blank problem.
On bug 134694, please see Naoki's comments #11.
(Reporter)

Comment 6

16 years ago
and another one that i forgot to mention: bug# 91682 (setting folder charset to
UTF-8 has the same effect)
(Reporter)

Comment 7

16 years ago
when i say "the same effect" i mean : no-mime headers are blank and the
application hangs after scrolling.
Summary: Changing folder properties to japanese-ISO-2022 turns nomime headres blank/freeze on scrolling → Changing folder properties to japanese-ISO-2022/or to UTF8 turns nomime headres blank/freeze on scrolling
(Assignee)

Comment 8

16 years ago
Created attachment 80967 [details]
Stack trace of infinite loop

Hang doesn't occure at first. You have to scroll few pages down.
I think one of newsgroup posting is a cause of this problem.

Comment 9

16 years ago
bug 132583 is about infinite loop problem in NS_ConvertUTF8toUCS2,
but the caller should avoid generating illegal UTF-8
(Reporter)

Comment 10

16 years ago
Roy,when you say  in your comment #8 that there is a specific posting that
causes a problem do you mean a specific article in kherson.commerce? I've seen
the same hang in relcom.cinema with the folder charset set to iso-2022ja or utf8. 
(Assignee)

Comment 11

16 years ago
>there is a specific posting that
>causes a problem do you mean a specific article in kherson.commerce?
Yes, but I failed to pin point which one(s)

>I've seen the same hang in relcom.cinema with the folder charset set to 
>iso-2022ja or utf8. 
It is entirely possible of having the same infinite loop.


(Reporter)

Comment 12

16 years ago
Roy,actually you might be right about a specific newsarticle after all,there is
no hang with a huge chinese newsgroup tw.bbs.comp.linux, unfortunately when the
hang happens with russian newsgroups and if at the time of the hang you had only
one mail account such as news then this account is gone! you have to add it
again...  
(Assignee)

Comment 13

16 years ago
Created attachment 81070 [details] [diff] [review]
Populate the unicode string with replacement char in case of decoder failure

This is one of the smallest change, I can think of, to fix this bug.
(I'd like to minimize the amount of the code changes before the release)

nhotta: can you review?

Comment 14

16 years ago
Comment on attachment 81070 [details] [diff] [review]
Populate the unicode string with replacement char in case of decoder failure

r=nhotta
Attachment #81070 - Flags: review+
(Reporter)

Comment 15

16 years ago
*** Bug 139954 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 16

16 years ago
Comment on attachment 81070 [details] [diff] [review]
Populate the unicode string with replacement char in case of decoder failure

sr=bienvenu
Attachment #81070 - Flags: superreview+

Comment 17

16 years ago
Comment on attachment 81070 [details] [diff] [review]
Populate the unicode string with replacement char in case of decoder failure

a=asa (on behalf of drivers) for checkin to the 1.0 branch
Attachment #81070 - Flags: approval+
(Assignee)

Comment 18

16 years ago
checked into the trunk.
ji: please verify the bug tomorrow. thanks
(Assignee)

Comment 19

16 years ago
Severity:
- Hang when simply scrolling mail headear

Impact Analysis:
- mail/news only fix
- no impact on Western encoding (since intl_is_utf8() returns True)
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 20

16 years ago
QA contact to marina. Marina, could you check this on tomorrow's trunk build.
Thanks.
QA Contact: ji → marina
(Reporter)

Comment 21

16 years ago
tested with 2002-04-30-10 trunk build, it is fixed, there is no freeze neither
hang after changing folder properties and scrolling.
(Assignee)

Comment 22

16 years ago
adding adt1.0.0 keyword

Severity:
- Hang when simply scrolling mail headear

Impact Analysis:
- mail/news only fix
- no impact on Western encoded mail (since intl_is_utf8() returns True)
Keywords: adt1.0.0

Updated

16 years ago
Keywords: adt1.0.0

Comment 23

16 years ago
Please get the bug VERIFIED and then re-nominate.
(Assignee)

Comment 24

16 years ago
syd: oops, i thought marina did it already. (comment #21) 
marina: please verify.
(Reporter)

Comment 25

16 years ago
in my comments #21 i said that this is fixed in the trunk, i was waiting for the
branch build to mark it "verified"
(Reporter)

Comment 26

16 years ago
verified on the trunk
Status: RESOLVED → VERIFIED
(Assignee)

Comment 27

16 years ago
add adt1.0.0 keyword
Keywords: adt1.0.0

Comment 28

16 years ago
adt, please consdier taking this. It is very likly to hang by this for Japanese
users using mail or newsgroup. When the uers view mail or news, it will hang if
the message does not include a mime charset but have 8 bits data. 
Keywords: intl

Comment 29

16 years ago
 adt1.0.0+ (on ADT's behalf) approval for checkin to the 1.0 brnach. Pls check
this in today, then add the fixed1.0.0 keyword.
Keywords: adt1.0.0 → adt1.0.0+
Whiteboard: [adt1] → [adt1] [ETA 05/03]
(Assignee)

Updated

16 years ago
Keywords: fixed1.0.0
(Assignee)

Comment 30

16 years ago
fix checked into the branch (keyword 'fixed1.0.0 added)
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.