Closed Bug 1398450 Opened 2 years ago Closed 2 years ago

capabilities::tests::test_prefs failure

Categories

(Testing :: geckodriver, defect)

Version 3
defect
Not set

Tracking

(firefox57 fixed)

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: ato, Assigned: ato)

References

Details

Attachments

(1 file)

We have a test regression in capabilities::tests::test_prefs in testing/geckodriver/src/capabilities.rs:

> thread 'capabilities::tests::test_prefs' panicked at 'assertion failed: `(left == right)`
>   left: `None`,
>  right: `Some(Pref { value: Int(2828), sticky: false })`', src/capabilities.rs:512:8
> note: Run with `RUST_BACKTRACE=1` for a backtrace.
> 
> 
> failures:
>     capabilities::tests::test_prefs
> 
> test result: FAILED. 6 passed; 1 failed; 0 ignored; 0 measured; 0 filtered out
Blocks: 1391605
Didn't I fix that already? I thought so... hm, so this is failing because we don't set this preference anymore. So best to remove.
Assignee: nobody → ato
Status: NEW → ASSIGNED
Comment on attachment 8906297 [details]
Bug 1398450 - Fix prefs test regression.

https://reviewboard.mozilla.org/r/178030/#review183202
Attachment #8906297 - Flags: review?(james) → review+
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/4e34fdb8b3ff
Fix prefs test regression. r=jgraham
https://hg.mozilla.org/mozilla-central/rev/4e34fdb8b3ff
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.