Intermittent browser/base/content/test/alerts/browser_notification_open_settings.js | Test timed out -

RESOLVED WORKSFORME

Status

()

defect
P1
normal
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure})

unspecified
mozilla58
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox56 unaffected, firefox57 fixed, firefox58 fixed)

Details

(Whiteboard: [stockwell unknown])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
treeherder
Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=129776911&repo=autoland

https://queue.taskcluster.net/v1/task/Cqb5x7M6TF2Uik0QXnD-tA/runs/0/artifacts/public/logs/live_backing.log

10:51:13     INFO -  22 INFO TEST-PASS | browser/base/content/test/alerts/browser_notification_open_settings.js | The notification settings tab opened -
10:51:13     INFO -  Buffered messages logged at 10:50:29
10:51:13     INFO -  23 INFO Leaving test bound test_settingsOpen_observer
10:51:13     INFO -  24 INFO Entering test bound test_settingsOpen_button
10:51:13     INFO -  25 INFO Adding notification permission
10:51:13     INFO -  26 INFO Console message: [JavaScript Warning: "Use of nsIFile in content process is deprecated." {file: "resource://gre/modules/FileUtils.jsm" line: 174}]
10:51:13     INFO -  Buffered messages logged at 10:50:30
10:51:13     INFO -  27 INFO Waiting for notification
10:51:13     INFO -  Buffered messages finished
10:51:13    ERROR -  28 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/alerts/browser_notification_open_settings.js | Test timed out -
Comment hidden (Intermittent Failures Robot)
This is blocking bug 1399401 from landing and I was asked to unblock it.

My guess is that the race is with the permission manager between processes. I think the test should switch to use SpecialPowers and await the perm change.
Assignee: nobody → MattN+bmo
Blocks: 1399401
Status: NEW → ASSIGNED
Priority: P5 → P3
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Whiteboard: [stockwell needswork]
retriggers didn't help pinpoint anything, if it did, then it would be:
https://hg.mozilla.org/integration/autoland/rev/3077f546e9b2ebfd05612e02c4ff1a872ae5a6e9

:mattn, I see this is assigned to you and it has really failed quite often in the last 5 days, can you help resolve this or give a thumbs up to disable it?
Flags: needinfo?(MattN+bmo)
Comment hidden (Intermittent Failures Robot)
given this hit our 200 failures in the last 30 days threshold, the robot flagged this as disable-recommended, we will do this later today or tomorrow unless we hear a fix is pending.
Comment hidden (Intermittent Failures Robot)
Not a Stylo test issue
Comment hidden (Intermittent Failures Robot)
I haven't had time to look at this unfortunately. Maybe eoger can look at it since he's been working on the alert service recently?
Flags: needinfo?(eoger)
Not sure if that helps since I couldn't reproduce, I followed what you said in comment 3.
Flags: needinfo?(eoger)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
thanks for getting a potential fix posted for review!  Can we get this reviewed and landed  quickly?
Comment on attachment 8916095 [details]
Bug 1398491 - Use SpecialPowers.pushPermissions instead of Services.perms.add.

https://reviewboard.mozilla.org/r/187332/#review192892
Attachment #8916095 - Flags: review?(MattN+bmo) → review+
Comment on attachment 8916095 [details]
Bug 1398491 - Use SpecialPowers.pushPermissions instead of Services.perms.add.

https://reviewboard.mozilla.org/r/187332/#review192896

::: browser/base/content/test/alerts/browser_notification_open_settings.js:29
(Diff revision 1)
>  
>  add_task(async function test_settingsOpen_button() {
> -  let pm = Services.perms;
>    info("Adding notification permission");
> -  pm.add(makeURI(notificationURL), "desktop-notification", pm.ALLOW_ACTION);
> +  await new Promise(res => {
> +    SpecialPowers.pushPermissions([{'type': 'desktop-notification', 'allow': true, 'context': notificationURL}], res);

This fails eslint since you should use double-quotes

Comment 27

2 years ago
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6fe7c6bdbb5b
Use SpecialPowers.pushPermissions instead of Services.perms.add in browser_notification_open_settings.js. r=MattN
Comment hidden (Intermittent Failures Robot)
https://hg.mozilla.org/mozilla-central/rev/6fe7c6bdbb5b
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Flags: needinfo?(MattN+bmo)
Assignee: MattN+bmo → eoger
Whiteboard: [stockwell disable-recommended] → [stockwell fixed:timing]
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [stockwell fixed:timing] → [stockwell needswork]
Reopened this bug because it is still failing. It has 49 failures in the last 7 days. The failure occurs on Windows 7 and Windows 10, on pgo, opt and debug build type.

Failing tests: mochitest-browser-chrome-e10s, mochitest-browser-chrome-4.

Link to a recent log:https://treeherder.mozilla.org/logviewer.html#?repo=autoland&job_id=145903829&lineNumber=1847

Part of the log:
11:58:23    ERROR -  14 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/alerts/browser_notification_open_settings.js | Test timed out -
1848
11:58:23     INFO -  GECKO(5908) | MEMORY STAT | vsize 1774MB | vsizeMaxContiguous 131826701MB | residentFast 237MB | heapAllocated 77MB
1849
11:58:23     INFO -  15 INFO TEST-OK | browser/base/content/test/alerts/browser_notification_open_settings.js | took 45104ms
1850
11:58:23     INFO -  Not taking screenshot here: see the one that was previously logged
1851
11:58:23    ERROR -  16 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/alerts/browser_notification_open_settings.js | Found a tab after previous test timed out: http://example.org/browser/browser/base/content/test/alerts/file_dom_notifications.html -
1852
11:58:23     INFO -  17 INFO checking window state
1853
11:58:23     INFO -  18 INFO TEST-START | browser/base/content/test/alerts/browser_notification_remove_permission.js
1854
11:59:08     INFO -  Not taking screenshot here: see the one that was previously logged
1855
11:59:08     INFO -  Buffered messages logged at 11:58:23
1856
11:59:08     INFO -  19 INFO openNotification: showNotification2
1857
11:59:08     INFO -  20 INFO Console message: [JavaScript Warning: "Use of nsIFile in content process is deprecated." {file: "resource://gre/modules/FileUtils.jsm" line: 174}]
1858
11:59:08     INFO -  Buffered messages finished
1859
11:59:08    ERROR -  21 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/alerts/browser_notification_remove_permission.js | Test timed out -
1860
11:59:08     INFO -  GECKO(5908) | MEMORY STAT | vsize 1772MB | vsizeMaxContiguous 131826701MB | residentFast 240MB | heapAllocated 77MB
1861
11:59:08     INFO -  22 INFO TEST-OK | browser/base/content/test/alerts/browser_notification_remove_permission.js | took 45070ms
1862
11:59:08     INFO -  23 INFO checking window state
1863
11:59:08     INFO -  24 INFO TEST-START | browser/base/content/test/alerts/browser_notification_replace.js
1864
11:59:53     INFO -  Not taking screenshot here: see the one that was previously logged
1865
11:59:53     INFO -  Buffered messages logged at 11:59:08
1866
11:59:53     INFO -  25 INFO Entering test bound test_notificationReplace
1867
11:59:53     INFO -  Buffered messages finished
1868
11:59:53    ERROR -  26 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/alerts/browser_notification_replace.js | Test timed out -
1869
11:59:53     INFO -  GECKO(5908) | MEMORY STAT | vsize 1777MB | vsizeMaxContiguous 131826701MB | residentFast 237MB | heapAllocated 75MB
1870
11:59:53     INFO -  27 INFO TEST-OK | browser/base/content/test/alerts/browser_notification_replace.js | took 45021ms
1871
11:59:53     INFO -  Not taking screenshot here: see the one that was previously logged
1872
11:59:53    ERROR -  28 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/alerts/browser_notification_replace.js | Found a tab after previous test timed out: http://example.org/browser/browser/base/content/test/alerts/file_dom_notifications.html -
1873
11:59:53     INFO -  29 INFO checking window state
1874
11:59:53     INFO -  30 INFO TEST-START | browser/base/content/test/alerts/browser_notification_tab_switching.js
1875
12:00:38     INFO -  Not taking screenshot here: see the one that was previously logged
1876
12:00:38     INFO -  Buffered messages logged at 11:59:53
1877
12:00:38     INFO -  31 INFO Entering test bound test_notificationPreventDefaultAndSwitchTabs
1878
12:00:38     INFO -  Buffered messages logged at 11:59:54
1879
12:00:38     INFO -  32 INFO TEST-PASS | browser/base/content/test/alerts/browser_notification_tab_switching.js | Notification page loaded as a background tab -
1880
12:00:38     INFO -  33 INFO openNotification: showNotification1
1881
12:00:38     INFO -  Buffered messages finished
 

:MattN could you please take a look at this?
Flags: needinfo?(MattN+bmo)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
I've informed my manager that all of the alert service b-c tests have been disabled due to intermittent failures but there are currently higher priorities projects.
Assignee: eoger → nobody
Status: REOPENED → NEW
Flags: needinfo?(MattN+bmo)
Priority: P3 → P1
closing this bug as a fix to the generic worker resolved issues- any remaining issues with the tests are not related to the worker upgrade.
Status: NEW → RESOLVED
Last Resolved: 2 years agoa year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.