Assertion failure: ((bool)(__builtin_expect(!!(!NS_FAILED_impl(rv)), 1))), at netwerk/protocol/ftp/FTPChannelParent.cpp:488

RESOLVED DUPLICATE of bug 1399467

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 1399467
10 months ago
10 months ago

People

(Reporter: bc, Unassigned)

Tracking

(Blocks: 1 bug, {assertion})

56 Branch
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
1. Load url. (not provided since it is probably an illegal movie download site). If you are working on this bug, please ping me on irc or email.

2. If it doesn't assert soon, reload the page. 

3. Assertion failure: ((bool)(__builtin_expect(!!(!NS_FAILED_impl(rv)), 1))), at /builds/worker/workspace/build/src/netwerk/protocol/ftp/FTPChannelParent.cpp:488
#01: mozilla::net::nsHttpChannel::CallOnStartRequest [netwerk/protocol/http/nsHttpChannel.cpp:1697]
#02: mozilla::net::nsHttpChannel::ContinueProcessNormal [netwerk/protocol/http/nsHttpChannel.cpp:2842]
#03: mozilla::net::nsHttpChannel::ProcessNormal [netwerk/protocol/http/nsHttpChannel.cpp:2775]
#04: mozilla::net::nsHttpChannel::ContinueProcessResponse2 [netwerk/protocol/http/nsHttpChannel.cpp:2654]
#05: mozilla::net::nsHttpChannel::ContinueProcessResponse1 [netwerk/protocol/http/nsHttpChannel.cpp:2487]
#06: mozilla::net::nsHttpChannel::ProcessResponse [netwerk/protocol/http/nsHttpChannel.cpp:2360]
#07: mozilla::net::nsHttpChannel::OnStartRequest [netwerk/protocol/http/nsHttpChannel.cpp:7139]
#08: nsInputStreamPump::OnStateStart [netwerk/base/nsInputStreamPump.cpp:536]

Windows / Linux; Beta 56, Nightly 57
I will mark this as dup of 1399467. If it appears not to be we can reopen it.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1399467
You need to log in before you can comment on or make changes to this bug.