Closed Bug 1398518 Opened 2 years ago Closed 10 months ago

Intermittent toolkit/components/extensions/test/mochitest/test_ext_notifications.html | Test timed out.

Categories

(WebExtensions :: General, defect, P3)

defect

Tracking

(firefox57 disabled, firefox58 disabled, firefox66 fixed, firefox67 fixed)

RESOLVED FIXED
mozilla67
Tracking Status
firefox57 --- disabled
firefox58 --- disabled
firefox66 --- fixed
firefox67 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: rpl)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed])

Attachments

(2 files)

:andym - This is failing quite frequently. Do you have a plan for resolving it?
Flags: needinfo?(amckay)
Not at this time.
Flags: needinfo?(amckay)
we will disable this tomorrow.
This didn't get flagged by my bugzilla query because I was looking for [stockwell needswork] but it was tagged with [stockwell needswork:owner]. Is that what I should now be looking for, Joel?
Flags: needinfo?(jmaher)
Assignee: nobody → bob.silverberg
Priority: -- → P3
sorry :bsilverberg, yes since you are managing your own please look for [stockwell needswork:owner] - lets change this and get it off the disabling list.
Flags: needinfo?(jmaher)
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]
Given that we are upcoming on a long weekend and this test is failing at a high rate, I would like to disable this until we get a fix in place.
Attachment #8915991 - Flags: review?(gbrown)
Attachment #8915991 - Flags: review?(gbrown) → review+
Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/85a4fbfc88ef
Disable toolkit/components/extensions/test/mochitest/test_ext_notifications.html for high frequency failures. r=gbrown
:bsilverberg, please remember to re enable this test when you get a fix ready to land.
Product: Toolkit → WebExtensions

Based on what I've been able to reproduce locally using --verify, there is a chance that
the notifications created by the test case named test_notifications_populated_getAll
may have been removed before the browser.notifications.getAll is going to retrieve them,
and when this happens the test gets stuck because browser.test.notifyPass("getAll populated");
is never reached, and the test timeouts.

This patch includes the following changes to prevent the intermittent failure described above:

  • add a new head_notifications.js support file and create a new MockAlertsService test helper that
    loads a chrome script which replace the alerts service with a mock service (based on a
    similar mock defined in dom/notification/test/mochitest/MockServices.js), the mocked alert
    service doesn't close the notification until the test case itself has called
    MockAlertsService.clearNotifications (so that the test shouldn't fail intermittently as
    described above).

  • applies the changes needed on test_ext_notifications.html to make use of the MockAlertsService

Assignee: bob.silverberg → lgreco
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/d2bb10ec687e
Fix test_ext_notifications.html intermittency and re-enable it. r=mixedpuppy
Status: NEW → RESOLVED
Closed: 10 months ago
Keywords: leave-open
Resolution: --- → FIXED
Whiteboard: [stockwell disabled] → [stockwell fixed]
Target Milestone: --- → mozilla67

From my understanding this issue is related to the addon tests. Is there any need of manual QA here? If not can you please mark it as "qe-verify- "

Flags: needinfo?(lgreco)
Flags: needinfo?(lgreco) → qe-verify-
See Also: → 1276214
You need to log in before you can comment on or make changes to this bug.