Message isn't marked as read in unified folder

RESOLVED DUPLICATE of bug 1387581

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 1387581
10 months ago
9 months ago

People

(Reporter: Zdenek Jindra, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.79 Safari/537.36

Steps to reproduce:

I set up a domain bin where anything@domain.org drops to the same mailbox. This creates mails with a recipient address different from the account address.


Actual results:

When selecting the delivered message in the 3-pane view, it stays bold and the green Unread bullet stays on. This does not happen with messages where the recipient matches the mailbox address.


Expected results:

The message line should be marked as read - not bold. I did check the settings and it works normally for messages with matching recipient to the account. I should note that this worked fine before version 52.

Comment 1

10 months ago
I don't think this is related to the recipient's address not matching the mailbox. There must be another problem.

What do you see on the error console? "Tools > Developer Tools > Error Console". Clear the console by clicking the little bin icon at the top left, then click onto the message to show it in the preview pane which should mark it read if the system is configured to do so (Tools > Options, Display, Advanced).
(Reporter)

Comment 2

10 months ago
(In reply to Jorg K (GMT+2) from comment #1)
> I don't think this is related to the recipient's address not matching the
> mailbox. There must be another problem.
> 
> What do you see on the error console? "Tools > Developer Tools > Error
> Console". Clear the console by clicking the little bin icon at the top left,
> then click onto the message to show it in the preview pane which should mark
> it read if the system is configured to do so (Tools > Options, Display,
> Advanced).

The console says nothing about this. I checked that all levels of errors are shown. That's what I also tried previously. I now suspect that my user profile is corrupted. I have a lot of archived mail I want to keep, so I'll have to live with this, I guess. I also tried to re-create the account and then put the old directory in its place, but the problem persists. I'm at a loss and I don't want to lose data.

Comment 3

10 months ago
Have you repaired the folder in question? Right-click, Properties, Repair Folder?

You can move old mail to a new profile, if it's POP mail/local folders. Just move the "Mail" folder from the old profile to the new. Make a backup before in case something goes wrong.
(Reporter)

Comment 4

10 months ago
(In reply to Jorg K (GMT+2) from comment #3)
> Have you repaired the folder in question? Right-click, Properties, Repair
> Folder?
> 
> You can move old mail to a new profile, if it's POP mail/local folders. Just
> move the "Mail" folder from the old profile to the new. Make a backup before
> in case something goes wrong.

Tried that many times, even manually deleted all .msf files. I'm now in the process of re-creating my profile by hand and I hope that when I swap the data with my old mails that the problem won't return.
(Reporter)

Comment 5

10 months ago
After all the work, the bug still persists, and now it affects all of my accounts. It's apparently related to Folders>Unified and doesn't do it in the default "All" view. I'd like to see my new mails in one list though.

Comment 6

10 months ago
So you're saying that this only happens in the "Unified Folders" View, not the "All Folders" view. I'm using "Unified Folders", but I don't use the unified inbox, instead I have a few inboxes listed.

Maybe related to bug 1387581.

Comment 7

10 months ago
I'm looking at bug 1387581 now, another problem where marking as read marks the wrong message. I'll have a fix soon which you can then try out.
(Reporter)

Comment 8

10 months ago
Thank you.

Comment 9

10 months ago
You haven't confirmed that we're talking about unified folders here, but I assume that is the case. I can reproduce the problem and we'll address it in bug 1387581.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Summary: Message isn't marked as read if the Recipient is different from the inbox e-mail → Message isn't marked as read in unified folder
Duplicate of bug: 1387581

Comment 10

9 months ago
The problem got fixed in bug 1387581, so you can try it out in the Daily of tomorrow, Sept. 12th, 2017:
http://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-central/
You need to log in before you can comment on or make changes to this bug.