'Title Bar' and 'Drag Space' checkbox labels in customization mode are impossible to read in dark theme

VERIFIED FIXED in Firefox 57

Status

()

P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: euthanasia_waltz, Assigned: dao)

Tracking

({nightly-community, regression})

57 Branch
Firefox 57
Unspecified
Windows
nightly-community, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 verified, firefox58 verified)

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Posted image screenshot
mozregression:
 5:36.64 INFO: Last good revision: 6ee4de08ac3767c4d15338f830dc3763d5da769a
 5:36.64 INFO: First bad revision: 563cbdd108d601c788b6d9b32092a6244ab7dc7f
 5:36.64 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6ee4de08ac3767c4d15338f830dc3763d5da769a&tochange=563cbdd108d601c788b6d9b32092a6244ab7dc7f

caused by bug 1396975

Updated

2 years ago
Blocks: 1396975
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Keywords: nightly-community, regression

Comment 1

2 years ago
I'll start working on a better spec for this.
Flags: needinfo?(abenson)
Great, thank you! (For the record, we discussed that it's probably best to adjust all footer items to dark mode, which will fix the reported bug as well).

Updated

2 years ago
Priority: -- → P3
Summary: 'Title Bar' checkbox label in customization mode with Dark theme is hard to read → 'Title Bar' checkbox label in customization mode with Dark theme is impossible to read
Whiteboard: [reserve-photon-structure]
Duplicate of this bug: 1399772
Summary: 'Title Bar' checkbox label in customization mode with Dark theme is impossible to read → 'Title Bar' and 'Drag Space' checkbox labels in customization mode are impossible to read in dark theme
(Assignee)

Comment 4

2 years ago
I think we should just fix this regression. A redesign should be a separate bug, which may or may not make it into 57.

Comment 5

2 years ago
(In reply to Dão Gottwald [::dao] from comment #4)
> I think we should just fix this regression. A redesign should be a separate
> bug, which may or may not make it into 57.

FWIW, I concur. Just making the checkbox text color white (or whatever the default foreground color is) in the cases where the background is black should work in the short-term, right?
(Assignee)

Updated

2 years ago
Blocks: 1399823
(Assignee)

Updated

2 years ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(abenson)
Priority: P3 → P1

Comment 7

2 years ago
mozreview-review
Comment on attachment 8908059 [details]
Bug 1398549 - Let the 'Title Bar' and 'Drag Space' checkboxes inherit the text color when a lightweight theme is applied.

https://reviewboard.mozilla.org/r/179768/#review184972

Thanks!
Attachment #8908059 - Flags: review?(gijskruitbosch+bugs) → review+

Comment 8

2 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b24b96e6f8a1
Let the 'Title Bar' and 'Drag Space' checkboxes inherit the text color when a lightweight theme is applied. r=Gijs
Flags: qe-verify+
QA Contact: gwimberly
https://hg.mozilla.org/mozilla-central/rev/b24b96e6f8a1
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Iteration: --- → 57.3 - Sep 19
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox-esr52: --- → unaffected
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20170921220243

This issue has been verified on latest Firefox Nightly Build ID: 20170921220243 on Windows 8.1 x64, Mac OS 10.12 and Ubuntu 14.04 and I cannot reproduce it. Now, the checkboxes from the bottom of the Customization page inherit the text color when a lightweight theme is applied.
(Assignee)

Updated

2 years ago
Status: RESOLVED → VERIFIED
status-firefox58: --- → verified
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170928180207

This issue has been verified on latest Firefox Beta 57.0b4 on Windows 8.1 x64, Mac OS 10.12 and Ubuntu 14.04 and I cannot reproduce it.
status-firefox57: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.