Closed Bug 1398579 Opened 2 years ago Closed 2 years ago

Drag and drop of messages between folders broken on Trunk

Categories

(Thunderbird :: Folder and Message Lists, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 57.0

People

(Reporter: jorgk, Assigned: jorgk)

References

Details

Attachments

(1 file)

Drag and drop of messages between folders broken on Trunk.

Most likely related to other drag and drop problems we're looking at in bug 1398383 and caused by bug 1199729.

Richard, you're using Daily, can you confirm? Problem should have started in yesterday's (Saturday's) Daily since the bug 1199729 landed on Friday.
Flags: needinfo?(richard.marti)
Confirmed with yesterday Daily (20170909).
Flags: needinfo?(richard.marti)
And does customising still work? That is, dragging a UI element onto a toolbar?
Flags: needinfo?(richard.marti)
Sorry, still working, tried in local build.
Flags: needinfo?(richard.marti)
Richard, can you see any drag and drop operation in a FF Nightly that's not working? Like dragging a bookmark (folder) to a different folder?
Flags: needinfo?(richard.marti)
DnD from one folder to an other works.
Flags: needinfo?(richard.marti)
Without grabbing the data at drop, this doesn't work any more. I get:
(count = dt.mozItemCount) == 0 in drop.

When grabbing a copy again in _onDragDrop, everything works as before.
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #8906406 - Flags: review?(acelists)
Looks like the dataTransfer presented at drag over is different from the one presented at drop, and when we're at drop, the one from the drag over has gone stale somehow. So grabbing a fresh copy at drop works. Also safer that way since drag over doesn't need to happen theoretically.
Comment on attachment 8906406 [details] [diff] [review]
1398579-dragndrop-folder-tree.patch (v1)

Review of attachment 8906406 [details] [diff] [review]:
-----------------------------------------------------------------

I don't understand why this is needed, but it does fix it for me.
Thanks for finding it out!
Attachment #8906406 - Flags: review?(acelists) → review+
As I said, M-C implemented a whole permission hierarchy of what you can do with the data during the various events:
https://hg.mozilla.org/mozilla-central/rev/65372115ac3b#l2.12

I'm not sure what the status is in the "dragover".

But since we only grab the object shell with this._currentTransfer = aEvent.dataTransfer; there is no guarantee that the object content is still the same when we come to the drop.

Anyway, I'll ask in bug 1199729.

Hey, Richard, the bookmark move doesn't quite work! - Bug 1398471.
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/aa24e4530762
Port bug 1199729 for folder tree drag and drop. Retrieve dataTransfer also at drop. r=aceman
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 57.0
Duplicate of this bug: 1398633
You need to log in before you can comment on or make changes to this bug.