Wrong rendering in Rust home page, problems with alignment of elements

RESOLVED DUPLICATE of bug 1390635

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1390635
a year ago
a year ago

People

(Reporter: ignaciocaamanio, Unassigned)

Tracking

57 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8906378 [details]
Firefox nightly result

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170910100150

Steps to reproduce:

Go to https://www.rust-lang.org/en-US/


Actual results:

Wrong alignment of elements within the editor div


Expected results:

Correct alignment of elements
(Reporter)

Comment 1

a year ago
Created attachment 8906379 [details]
Google Chrome result
Component: Untriaged → Layout: Text
OS: Unspecified → Linux
Product: Firefox → Core
(Reporter)

Updated

a year ago
Hardware: Unspecified → x86_64
Nothing too challenging in the CSS:

#editor {
  padding: none;
  margin: none;
  width: 100%;
  min-height: 300px;
  font-size: 13px;
  font-family: Menlo, Monaco, Consolas, "Courier New", monospace;
  white-space: pre-wrap;
}

I wasn't able to reproduce this one. Does it still occur reliably for you?
Flags: needinfo?(ignaciocaamanio)
Priority: -- → P3
(Reporter)

Comment 3

a year ago
I can reproduce. The lines with non ascii characters use more vertical space and overlap with the other lines. I tried with google chrome (see attachment) and some characters are missing but alignment is ok, maybe it's something with my system's fonts?

I don't know what is "needinfo", sorry I'm new...
Flags: needinfo?(ignaciocaamanio)
Dupe of bug 1390635. (Yes, the result you see is somewhat dependent on your system's fonts. The page's styling makes assumptions about font sizing that don't hold true across a variety of -- particularly non-Latin -- fonts.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1390635
You need to log in before you can comment on or make changes to this bug.