Cannot add an opensearch search engine from a web page using the default toolbar layout

RESOLVED DUPLICATE of bug 1221539

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1221539
2 months ago
2 months ago

People

(Reporter: Bonstra, Unassigned)

Tracking

({dupeme})

57 Branch
dupeme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170910100150

Steps to reproduce:

1) Open Nightly with a blank profile
2) Type https://crates.io/ in the address bar and press return
3) Try to add crates.io to the list of search engines


Actual results:

I cannot find an easy way to add crates.io as a search engine.
I had to customize the toolbar to add the search bar, click on the magnifying glass with the + sign in the search bar, and click 'Add "Cargo"'.


Expected results:

I would have expected either of those:
- the "Page actions" menu in the address bar to contain an item such as 'Add "Cargo" to search engines'
- the context menu entry which appears on a right-click on the page background to contains an entry to add "Cargo" as search engine
- a button 'Add "Cargo" as search engine' in the address bar's "Show history" drop down menu where all search engines are listed

The search bar still allows to add an opensearch search engine from a web page, but it is absent from the default toolbar layout.

Comment 1

2 months ago
Adding search engine should be available in address bar popup, like Beyond Australis.
Status: UNCONFIRMED → NEW
Component: Untriaged → Search
Ever confirmed: true
Keywords: dupeme
Whiteboard: [photon-structure]
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1221539

Updated

2 months ago
Whiteboard: [photon-structure]
You need to log in before you can comment on or make changes to this bug.