[Linux] Regression in updater performance

RESOLVED INVALID

Status

()

RESOLVED INVALID
a year ago
a year ago

People

(Reporter: marco, Unassigned)

Tracking

({regression})

unspecified
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(firefox55 unaffected, firefox56 unaffected, firefox57 fix-optional)

Details

(Reporter)

Description

a year ago
I hardly ever saw the progress dialog "Nightly is applying updates ...". Now I see it every time I start Nightly.
That is expected now that update staging has been disabled due to bug 1397562.
Blocks: 1397562
Summary: Regression in updater performance → [Linux] Regression in updater performance
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox57: --- → affected
I've noticed this as well.
status-firefox57: affected → fix-optional
Jim, which platform?
Flags: needinfo?(jmathies)
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #3)
> Jim, which platform?

Windows Nightly, I think two daily nightly builds is probably impacting my perception a bit.
Flags: needinfo?(jmathies)
That is most likely why since staging has been disabled on Windows for a long time now.
As this is not a regression per se, but rather the result of disabling staging of updates, this is expected behavior.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
Note: we will reevaluate whether to re-enable or remove staging when there is more time / resources to do so.
You need to log in before you can comment on or make changes to this bug.