Total div size cannot exceed approximately 17 million px in height

RESOLVED DUPLICATE of bug 265084

Status

()

Core
Layout
P3
normal
RESOLVED DUPLICATE of bug 265084
10 months ago
9 months ago

People

(Reporter: markrdelossantos, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
Created attachment 8906494 [details]
ff_height_bug.html

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36

Steps to reproduce:

Fill a div with content summing up to a minimum of 17 million px in height
(see attached file)


Actual results:

Bottom content is clipped


Expected results:

Bottom content should not be clipped

Updated

10 months ago
Component: Untriaged → Layout
Product: Firefox → Core

Updated

9 months ago
Priority: -- → P3
Yeah, our layout system uses a fixed-point representation, with 60 "nscoord" / "app units" per pixel (by default), so we can't represent arbitrarily large sizes.

To give ourselves a little headroom, we define the maximum supported size as 2^30 - 1, and when you divide that by 60 (to convert to pixels), you get 17,895,697.05, i.e. 17 million pixels.
https://dxr.mozilla.org/mozilla-central/rev/ffe6cc09ccf38cca6f0e727837bbc6cb722d1e71/gfx/src/nsCoord.h#49

We've discussed using a float representation instead of fixed-point (bug 265084), but I'm not sure if/when that'll happen. In any case, this is effectively a duplicate of that bug, i.e. it's the same underlying cause.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 265084
You need to log in before you can comment on or make changes to this bug.