Checkbox/radiobutton visualization does not change when changing its state

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
P3
normal
RESOLVED WORKSFORME
8 months ago
8 months ago

People

(Reporter: Dainius, Unassigned, NeedInfo)

Tracking

({regression, regressionwindow-wanted})

55 Branch
Unspecified
Linux
regression, regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170910220126

Steps to reproduce:

What I do to reproduce the bug:
1. Upgrade to Firefox 55
2. Try checking the checkbox or selecting a radio button on any webpage


Actual results:

The appearance of the checkbox/radio button does not change when clicking on it, but the actual state changes normally (as can be indicated by the behavior).


Expected results:

The checkbox/radio button should appear as checked/selected.

The problem can be reproduced in a new profile.
The problem can be reproduced on the latest Nightly (Build ID 20170910220126).
My system is running Fedora 19.
(Reporter)

Comment 1

8 months ago
Tested with versions 55.0, 55.0.1 - the problem CAN be reproduced
Tested with versions 54.0.b9, 54.0.1 - the problem CANNOT be reproduced

Updated

8 months ago
Component: Untriaged → Layout: Form Controls
Keywords: regression, regressionwindow-wanted
OS: Unspecified → Linux
Product: Firefox → Core

Comment 2

8 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Version: 57.0a1; Build ID: 20170912013600

Hello,

I have tested this issue on latest Firefox release (55.0.3), latest Nightly build using Ubuntu 14.04 x 64 and Fedora 23 x 64 and could not reproduce it. Clicking the radio buttons and checkboxes from https://www.w3schools.com/code/tryit.asp?filename=FJGWF3KW1J97 correctly selects or checks the boxes. 

I've also used an older Firefox release version 54.0, upgraded it to latest version and I still wasn't able to reproduce it.

Can you please retest using the same link I used and report back the results? Or can you provide me a specific example of website where you encountered this issue?
Flags: needinfo?(stankeviciaus)
(Reporter)

Comment 3

8 months ago
I have retested using the same link and the issue remains there. In general, the issue is reproducible in any website for me.

Updated

8 months ago
Flags: needinfo?(stankeviciaus)

Comment 4

8 months ago
Hello Dainius,

Since the issue seems to be related to your set-up, could you please use the mozregression tool to find a regression window? Information on the tool is available at http://mozilla.github.io/mozregression/. Please don't hesitate to contact us if you encounter any problems.
Flags: needinfo?(stankeviciaus)

Updated

8 months ago
Priority: -- → P3

Comment 5

8 months ago
WFM per comment 2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.