If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

M1RC1 topcrash [@ MSVCRT.DLL - PR_Free]

RESOLVED DUPLICATE of bug 138877

Status

()

Core
XPCOM
RESOLVED DUPLICATE of bug 138877
16 years ago
16 years ago

People

(Reporter: Jan Carpenter, Assigned: dougt)

Tracking

({crash, topcrash})

Trunk
x86
Windows NT
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

16 years ago
This stack signature is a topcrasher for M1RC1

Count           Offset         Real Signature
[ 5   MSVCRT.DLL + 0xd269 (0x7800d269) ef2770a0 - PR_Free ]
[ 5   MSVCRT.DLL + 0xcb04 (0x7800cb04) 67815e5b - PR_Free ]
[ 2   MSVCRT.DLL + 0xb936 (0x7800b936) 49537e90 - PR_Free ]
[ 4   MSVCRT.dll + 0xd203 (0x7800d203) 5811e4cc - PR_Free ]
[ 3   MSVCRT.dll + 0xd053 (0x7800d053) 6f76e3fd - PR_Free ]
[ 3   msvcrt.dll + 0x3203b (0x77c4203b) bcb01f40 - apply_rfc2047_encoding ]
 
     Crash date range: 2002-04-19 to 2002-04-22
     Min/Max Seconds since last crash: 13 - 262776
     Min/Max Runtime: 34 - 262776
     Keyword List :  
     Count   Platform List 
     7   Windows NT 4.0 build 1381
     6   Windows 98 4.10 build 67766446
     5   Windows 98 4.10 build 67766222
     3   Windows NT 5.1 build 2600
     1   Windows 98 4.90 build 73010104
 
     Count   Build Id List 
     22   2002041717
 
     No of Unique Users        13
 
 Stack trace(Frame) 

	 MSVCRT.DLL + 0xd269 (0x7800d269)  
	 MSVCRT.DLL + 0xcc3f (0x7800cc3f)  
	 PR_Free
[../../../../pr/src/malloc/prmem.c  line 504] 
	 nsMemoryImpl::Free
[d:\builds\seamonkey\mozilla\xpcom\base\nsMemoryImpl.cpp  line 343] 
	 nsStrPrivate::Free
[d:\builds\seamonkey\mozilla\string\obsolete\nsStr.cpp  line 1106] 
	 nsCString::~nsCString
[d:\builds\seamonkey\mozilla\string\obsolete\nsString.cpp  line 104] 
	 nsStandardURL::~nsStandardURL
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStandardURL.cpp  line 331] 
	 nsResURL::`scalar deleting destructor'  
	 nsStandardURL::Release
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStandardURL.cpp  line 820] 
	 nsCOMPtr_base::~nsCOMPtr_base
[d:\builds\seamonkey\mozilla\xpcom\glue\nsCOMPtr.cpp  line 65] 
	 nsHTMLDocument::GetBaseURL
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLDocument.cpp  line
1197] 
	 nsGenericHTMLElement::GetBaseURL
[d:\builds\seamonkey\mozilla\content\html\content\src\nsGenericHTMLElement.cpp 
line 2326] 
	 nsHTMLAnchorElement::GetHrefCString
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLAnchorElement.cpp 
line 782] 
	 nsStyleUtil::IsHTMLLink
[d:\builds\seamonkey\mozilla\content\shared\src\nsStyleUtil.cpp  line 659] 
	 RuleProcessorData::RuleProcessorData
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSStyleSheet.cpp  line 3308] 
	 StyleSetImpl::ResolveStyleFor
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp  line 1102] 
	 nsPresContext::ResolveStyleContextFor
[d:\builds\seamonkey\mozilla\layout\base\src\nsPresContext.cpp  line 973] 
	 nsCSSFrameConstructor::ResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 6580] 
	 nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7047] 
	 nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11999] 
	 nsCSSFrameConstructor::ConstructTableCellFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2741] 
	 nsCSSFrameConstructor::TableProcessChild
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 3005] 
	 nsCSSFrameConstructor::TableProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2899] 
	 nsCSSFrameConstructor::ConstructTableRowFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2585] 
	 nsCSSFrameConstructor::TableProcessChild
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2991] 
	 nsCSSFrameConstructor::TableProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2899] 
	 nsCSSFrameConstructor::ConstructTableRowGroupFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2476] 
	 nsCSSFrameConstructor::TableProcessChild
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2985] 
	 nsCSSFrameConstructor::TableProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2899] 
	 nsCSSFrameConstructor::ConstructTableFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2357] 
	 nsCSSFrameConstructor::ConstructFrameByDisplayType
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 6380] 
	 nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7214] 
	 nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7063] 
	 nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11999] 
	 nsCSSFrameConstructor::ConstructTableCellFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2741] 
	 nsCSSFrameConstructor::TableProcessChild
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 3005] 
	 nsCSSFrameConstructor::TableProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2899] 
	 nsCSSFrameConstructor::ConstructTableRowFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2585] 
	 nsCSSFrameConstructor::TableProcessChild
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2991] 
	 nsCSSFrameConstructor::TableProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2899] 
	 nsCSSFrameConstructor::ConstructTableRowGroupFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2476] 
	 nsCSSFrameConstructor::TableProcessChild
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2985] 
	 nsCSSFrameConstructor::TableProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2899] 
	 nsCSSFrameConstructor::ConstructTableFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2357] 
	 nsCSSFrameConstructor::ConstructFrameByDisplayType
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 6380] 
	 nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7214] 
	 nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7063] 
	 nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11999] 
	 nsCSSFrameConstructor::ConstructTableCellFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2741] 
	 nsCSSFrameConstructor::TableProcessChild
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 3005] 
	 nsCSSFrameConstructor::TableProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2899] 
	 nsCSSFrameConstructor::ConstructTableRowFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2585] 
	 nsCSSFrameConstructor::TableProcessChild
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2991] 
	 nsCSSFrameConstructor::TableProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2899] 
	 nsCSSFrameConstructor::ConstructTableRowGroupFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2476] 
	 nsCSSFrameConstructor::TableProcessChild
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2985] 
	 nsCSSFrameConstructor::TableProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2899] 
	 nsCSSFrameConstructor::ConstructTableFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 2357] 
	 nsCSSFrameConstructor::ConstructFrameByDisplayType
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 6380] 
	 nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7214] 
	 nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7063] 
	 nsCSSFrameConstructor::ContentAppended
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 8217] 
	 StyleSetImpl::ContentAppended
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp  line 1500] 
	 PresShell::ContentAppended
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5171]  
 
     (5489978)	URL: Composing email message. 
     (5489978)	Comments: Composing email message. Adding a phrase from the Windows XP
clipboard to the Subject line of the message. The message already had a phrase.
     (5487104)	URL: http://slashdot.org/articles/02/04/22/1719218.shml?tid=109
     (5487104)	Comments: thirst time it crashed after 3 days intensive web browsing. I fear
the crash is barely reproducable
     (5486391)	URL: slashdot.org
     (5486391)	Comments: Clicked on this link:
http://slashdot.org/articles/02/04/22/1719218.shtml?tid=109happened twice.
     (5486289)	Comments: clicked on a link on slashdot.org to one of their stories
     (5486180)	URL: www.slashdot.org
     (5485474)	URL: www.slashdot.org
     (5485474)	Comments: I clicked on a link
     (5485455)	URL: slashdot.org
     (5485455)	Comments: opening link in a new tab
     (5485251)	URL: slashdot.org
     (5485251)	Comments: Well whaddya know  it happened again just now.
     (5485240)	URL: slashdot.org
     (5485240)	Comments: clicking link
     (5485212)	URL:
http://slashdot.org/article.pl?sid=02/04/22/1719218&mode=thread&tid=109&threshold=3
     (5485212)	Comments: just clicked on a link at slashdot
     (5485142)	URL: slashdot.org
     (5485142)	Comments: Right-clicking  opening a bunch of tabs at once. The fourth tab
(to Brunching Shuttlecocks) caused a GPF  just poof.
     Count   Offset    Real Signature
[ 3   MSVCRT.DLL + 0xd203 (0x7800d203) 0469c4d6 - PR_Free ]
[ 3   MSVCRT.dll + 0xd053 (0x7800d053) eab5c9a5 - PR_Free ]
[ 2   MSVCRT.dll + 0xd203 (0x7800d203) 63aaa623 - PR_Free ]
[ 2   MSVCRT.dll + 0xd0c8 (0x7800d0c8) 4fbbbd63 - PR_Free ]
[ 2   MSVCRT.dll + 0xcb04 (0x7800cb04) 09a5c8fe - PR_Free ]
[ 2   MSVCRT.dll + 0x1845 (0x78001845) 0a7aa354 - PR_Free ]
[ 1   MSVCRT.dll + 0xd5ee (0x7800d5ee) b249de2c - PR_Free ]
[ 1   MSVCRT.dll + 0xd278 (0x7800d278) b62c2312 - PR_Free ]
[ 2   msvcrt.dll + 0x326e8 (0x77c426e8) 835d83c9 - hpcrd02.dll + 0x755f
(0x5000755f) ]
 

     Crash date range: 2002-04-21 to 2002-04-22
     Min/Max Seconds since last crash: 9 - 58335
     Min/Max Runtime: 388 - 259617
     Keyword List :  
     Count   Platform List 
     13   Windows NT 4.0 build 1381
     3   Windows 98 4.90 build 73010104
     2   Windows NT 5.1 build 2600
 
     Count   Build Id List 
     18   2002041717
 
     No of Unique Users        14
 
     (5487525)	URL: http://www.slashdot.org
     (5487525)	Comments: trying to load an article describing preditory behavior by microsoft
     (5487165)	URL: http://slashdot.org/articles/02/04/22/1719218.shtml?tid=109
     (5487165)	Comments: Tried to load the location
     (5487154)	URL: http://slashdot.org/articles/02/04/22/1719218.shml?tid=109
     (5486242)	URL: /.
     (5486242)	Comments: Clicked on a /. article about M$ and NW schools and it crashed.
     (5485580)	URL: slashdot.org
     (5485580)	Comments: attempting to load page.
     (5484540)	URL: http://www.slashdot.org
     (5484456)	URL: http://www.slashdot.org
     (5484456)	Comments: Clicked on a link to a story on slashdot
(Reporter)

Updated

16 years ago
Keywords: crash, topcrash
(Assignee)

Comment 1

16 years ago
dup.

*** This bug has been marked as a duplicate of 138877 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ MSVCRT.DLL - PR_Free]
You need to log in before you can comment on or make changes to this bug.