Spacing around address bar is messed up

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: rpollock, Unassigned)

Tracking

({regression})

57 Branch
x86_64
Windows 10
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8906706 [details]
large-gap-before-address-bar.png

The layout of icons to the right and left of the address bar is messed up. Lot of extra space.

see the attached screenshot

taken on my Surface Laptop
(Reporter)

Updated

a year ago
Keywords: regression
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox-esr52: --- → unaffected
Priority: P1 → --
Whiteboard: [photon-visual] [triage]
Target Milestone: Firefox 57 → ---
This is by design and expected to give better visual distinction for functional areas, you can right click on those spaces select Customize and drag them off, if you don't like them.

(Please don't play with priorities)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
Whiteboard: [photon-visual] [triage] → [photon-visual]
Whiteboard: [photon-visual]
(Reporter)

Comment 2

a year ago
You can say it's working as intended, but this looks broken. I'll ping Madhava.
yep, UX is the right goto.
Replied in an email, but here to close the loop:

Intentional! It centers the bar, makes it read a bit more as an element vs. a window-wide field,  makes more space apparent for customization, and visually distinguishes from Chrome. Safari does something similar, for, I would guess, the same reasons.

Live with it a bit -- chrome's window-wide field now feels weird to me.
You need to log in before you can comment on or make changes to this bug.