bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

make reftest-no-accel run on windows 10 (hardware) instead of windows 8

RESOLVED FIXED in Firefox 57

Status

Testing
Reftest
RESOLVED FIXED
10 months ago
10 months ago

People

(Reporter: jmaher, Assigned: jmaher)

Tracking

(Depends on: 2 bugs)

Trunk
mozilla57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(1 attachment)

Comment hidden (empty)
failures in Ru jobs:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=014799f4c401f271d60c20a3f2d5970478978599&filter-searchStr=Ru&exclusion_profile=false

Ru1 failures:
 REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/abs-pos/select-3.html == file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/abs-pos/select-3-ref.html | image comparison, max difference: 143, number of differing pixels: 107

REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/text-overflow/scroll-rounding.html == http://localhost:49843/1504879990040/186/text-overflow/scroll-rounding-ref.html | image comparison, max difference: 149, number of differing pixels: 1454

REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/columns/fieldset-columns-001.html == file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/columns/fieldset-columns-001-ref.html | image comparison, max difference: 142, number of differing pixels: 223


Ru2 failures:
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/forms/display-block-baselines-1.html == file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/forms/display-block-baselines-1-ref.html | image comparison, max difference: 88, number of differing pixels: 624

REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/forms/fieldset/positioned-container-1.html == file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/forms/fieldset/positioned-container-1-ref.html | image comparison, max difference: 142, number of differing pixels: 223

REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/forms/input/text/size-1.html == file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/forms/input/text/size-1-ref.html | image comparison, max difference: 151, number of differing pixels: 94

REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/position-dynamic-changes/relative/move-right-bottom.html == file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/position-dynamic-changes/relative/move-right-bottom-ref.html | image comparison, max difference: 149, number of differing pixels: 474

REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/position-dynamic-changes/relative/move-top-left.html == file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/position-dynamic-changes/relative/move-top-left-ref.html | image comparison, max difference: 149, number of differing pixels: 474

REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/position-dynamic-changes/relative/move-right-bottom-table.html == file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/position-dynamic-changes/relative/move-right-bottom-table-ref.html | image comparison, max difference: 144, number of differing pixels: 482

REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/position-dynamic-changes/relative/move-top-left-table.html == file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/position-dynamic-changes/relative/move-top-left-table-ref.html | image comparison, max difference: 144, number of differing pixels: 482

REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/scrolling/less-than-scrollbar-height.html == file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/scrolling/less-than-scrollbar-height-ref.html | image comparison, max difference: 149, number of differing pixels: 3730

REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/svg/svg-integration/box-decoration-break-02.xhtml == file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/svg/svg-integration/box-decoration-break-02-ref.xhtml | image comparison, max difference: 62, number of differing pixels: 4
Depends on: 1398918
Depends on: 1398919
out of the 12 failures above, I have:
Bug 1398918 - 5 failures in |R & A Pos|
Bug 1398919 - 3 failures in |Form Control|

I wonder if there is a root cause to fix those and then reevaluate the remaining 4 failures.
Created attachment 8908175 [details] [diff] [review]
migrate reftest-no-accel to win10, adjust all expectations

here is a try push showing how green this is:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=96de8c90a1fc689af6082d4873db9ac131726cb5&filter-tier=1&filter-tier=2&filter-tier=3
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
Attachment #8908175 - Flags: review?(bugs)
Attachment #8908175 - Flags: review?(ahalberstadt)
Comment on attachment 8908175 [details] [diff] [review]
migrate reftest-no-accel to win10, adjust all expectations

Review of attachment 8908175 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, lgtm!
Attachment #8908175 - Flags: review?(ahalberstadt) → review+

Updated

10 months ago
Attachment #8908175 - Flags: review?(bugs) → review+

Comment 5

10 months ago
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ba27e91673d0
make reftest-no-accel run on windows 10 (hardware) instead of windows 8. r=ahal,jet

Comment 6

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ba27e91673d0
Status: ASSIGNED → RESOLVED
Last Resolved: 10 months ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.