Fix strict ordering of data and stop request events with cross-thread stream filters

RESOLVED FIXED in Firefox 57

Status

defect
P1
normal
RESOLVED FIXED
2 years ago
10 months ago

People

(Reporter: kmag, Assigned: kmag)

Tracking

unspecified
mozilla57
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
When data delivery is not on the same thread as the StreamFilterParent actor, it's sometimes possible for the OnStopRequest to be dispatched on the main thread before the last OnDataAvailable event has been processed on the IO thread, which causes issues for listeners that expect it to be otherwise.
Comment hidden (mozreview-request)

Comment 2

2 years ago
mozreview-review
Comment on attachment 8907197 [details]
Bug 1399005: Always dispatch OnStop from the IO thread.

https://reviewboard.mozilla.org/r/178870/#review183986
Attachment #8907197 - Flags: review?(mixedpuppy) → review+
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1399273

Updated

2 years ago
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/9a676cb6f09a
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57

Comment 6

2 years ago
Is manual testing required on this bug? If Yes, please provide some STR and the proper webextension(if required), if No set the “qe-verify-“ flag.
Flags: needinfo?(kmaglione+bmo)
(Assignee)

Updated

a year ago
Flags: needinfo?(kmaglione+bmo) → qe-verify-

Updated

10 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.