Firefox hangs and uses excessive CPU

NEW
Unassigned

Status

()

Core
Layout: Form Controls
P3
critical
3 months ago
7 days ago

People

(Reporter: Brad Walker, Unassigned)

Tracking

({crash, crashreportid})

55 Branch
x86_64
Windows
crash, crashreportid
Points:
---

Firefox Tracking Flags

(firefox56 affected, firefox57 unaffected, firefox58 ?)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

3 months ago
This bug was filed from MDN. Firefox is hanging, and manually crashing produces this crash report: 

After upgrading our version of Firefox, we aren't able to use dropdown list containing a large amount of items (at least several hundred).  Firefox hangs, uses 100% of a CPU core, and we get a script debug window.  I went back to use an older version of Firefox 53.X and did not have this problem. Note that this issue only appears to happen on Citrix servers which run Server 2012 R2. Note that the URLs in question are on our intranet (sharepoint and SSRS)


Please include any other information such as steps to reproduce.

bp-a94b4ec4-faf9-41ac-b429-a33090170912 - https://crash-stats.mozilla.com/report/index/bp-895f7e66-c78c-467b-a2a6-d2da51170912

bp-5f35704e-adb8-4ac9-bff1-ee29e0170912 - https://crash-stats.mozilla.com/report/index/bp-5f35704e-adb8-4ac9-bff1-ee29e0170912

Updated

3 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Keywords: crash, crashreportid
Resolution: --- → DUPLICATE
Duplicate of bug: 1376200
(Reporter)

Comment 2

3 months ago
I don't think this bug is the same as 1376200. We also receive a script error every time: 

script: chrome://global/content/bindings/text.xml 36
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Updated

3 months ago
Hardware: x86 → x86_64
(Reporter)

Comment 3

3 months ago
I found this if I enable ANY type of add-in, that the issue does not occur. If I then disable the add-in, the issue happens once again
(Reporter)

Comment 4

3 months ago
Confirmed this behavior on Windows 10, Server 2008 R2, and Server 2012 R2
Component: Untriaged → Untriaged
Product: Firefox → Core

Comment 5

3 months ago
Jim, can you please take a look at the crash reports provided by Brad?
Also, Brad, can you please attach the "about:support" page in a .txt document for the machine described in comment 4? You can do this by navigating to "about:support" page and click on the "Copy raw data to clipboard" button.
Flags: needinfo?(jmathies)
Flags: needinfo?(bwalker)
(Reporter)

Comment 6

3 months ago
Created attachment 8910298 [details]
about:support raw data

Hello, here is the about:support information that you requested
Flags: needinfo?(bwalker)

Comment 7

3 months ago
(In reply to Brad Walker from comment #0)
> bp-a94b4ec4-faf9-41ac-b429-a33090170912
> https://crash-stats.mozilla.com/report/index/bp-895f7e66-c78c-467b-a2a6-d2da51170912

This crash happens in a new background thread, which is attempting to call the system's dll load entry point from within our dll interceptor code. The function pointer we try to invoke though is null. This is after the browser is up and running (uptime of 116 seconds). A bit of a mystery at this point. 

Took a look at the modules list but I don't see anything 3rd party / anti-virus in our process space. Another mystery since these types of crashes are usually caused by 3rd party software injection.

Comment 3 is also throwing me a bit, extension role in this is unknown.

Brad, are you running any form of anti-virus or corporate sign-on assistance or corporate snoop software on these machines?
Flags: needinfo?(bwalker)
(Reporter)

Comment 8

3 months ago
We run McAfee Enterprise 8.8.  No snoop software
Flags: needinfo?(bwalker)

Comment 9

3 months ago
(In reply to Brad Walker from comment #0)
> This bug was filed from MDN. Firefox is hanging, and manually crashing
> produces this crash report: 
> 
> After upgrading our version of Firefox, we aren't able to use dropdown list
> containing a large amount of items (at least several hundred).  Firefox
> hangs, uses 100% of a CPU core, and we get a script debug window.  I went
> back to use an older version of Firefox 53.X and did not have this problem.
> Note that this issue only appears to happen on Citrix servers which run
> Server 2012 R2. Note that the URLs in question are on our intranet
> (sharepoint and SSRS)
> 
> 
> Please include any other information such as steps to reproduce.
> 
> bp-a94b4ec4-faf9-41ac-b429-a33090170912 -
> https://crash-stats.mozilla.com/report/index/bp-895f7e66-c78c-467b-a2a6-
> d2da51170912
> 
> bp-5f35704e-adb8-4ac9-bff1-ee29e0170912 -
> https://crash-stats.mozilla.com/report/index/bp-5f35704e-adb8-4ac9-bff1-
> ee29e0170912

Reading back over this, I think maybe you've just hit bug 1118086. If you let the browser sit for a second, does the menu eventually populate?
Flags: needinfo?(jmathies)
(Reporter)

Comment 10

3 months ago
I don't think this is the same issue as bug 1118086.  The menu never becomes usable even after several minutes. The browser completely freezes up unless I stop the script running on the page but the menu still doesn't work even after stopping the script

Updated

2 months ago
Crash Signature: [@ @0x0 | patched_BaseThreadInitThunk ]
See Also: → bug 1376200

Comment 11

2 months ago
(In reply to Brad Walker from comment #10)
> I don't think this is the same issue as bug 1118086.  The menu never becomes
> usable even after several minutes. The browser completely freezes up unless
> I stop the script running on the page but the menu still doesn't work even
> after stopping the script

If this happens when using a drop-down menu with a large number of items, this is certainly a duplicate of bug 1118086.  The amount of time it takes for the menu to open up depends on the number of items in the menu (the test case we had on the bug had 10,000 elements in it) and the speed of the machine, etc.

If you stop the script as it is running, the menu will never open up and that's expected (even though undesirable, of course.)
(Reporter)

Comment 12

2 months ago
I am not stopping the script. The script never finishes running from what I can see. If you let the script continue to run, the browser freezes indefinitely.  Why does enabling at least one add-on to Firefox resolve the issue and why doesn't 53.X have this issue?

Comment 13

2 months ago
Do you mind please going to about:support in both a 53.x build and when you enable one add-on and select Copy Text To Clipboard and paste the results here separately?  My suspicion is that in both cases what's happening is that Firefox is going into single process mode, where we don't have the performance problem with large drop-down lists, and that's what causes the performance problem to go away for you.  Having the about:support output in those two modes would allow me to confirm this theory.

Comment 14

2 months ago
Hello Brad,

Can you please provide the requested info from comment 13? Thanks.
Flags: needinfo?(bwalker)
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
status-firefox56: --- → affected
status-firefox57: --- → ?
status-firefox58: --- → ?
(Reporter)

Comment 16

2 months ago
(In reply to Cristina Badescu from comment #14)
> Hello Brad,
> 
> Can you please provide the requested info from comment 13? Thanks.

Hello,

Sorry I have been out of the office. I will try to have this done this week

Thanks,

Brad
Flags: needinfo?(bwalker)
(Reporter)

Comment 17

2 months ago
(In reply to Brad Walker from comment #16)
> (In reply to Cristina Badescu from comment #14)
> > Hello Brad,
> > 
> > Can you please provide the requested info from comment 13? Thanks.
> 
> Hello,
> 
> Sorry I have been out of the office. I will try to have this done this week
> 
> Thanks,
> 
> Brad

Hello,

Here are the results with add-ons on version 53.X. I took out the printer names and URI's for privacy reasons

Application Basics
------------------

Name: Firefox
Version: 53.0b9
Build ID: 20170403072723
Update Channel: beta
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
OS: Windows_NT 10.0
Multiprocess Windows: 0/1 (Disabled)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Application Update Service Helper
Version: 2.0
Enabled: true
ID: aushelper@mozilla.org

Name: McAfee Endpoint Security Web Control
Version: 10.2.0.271
Enabled: true
ID: {cb40da56-497a-4add-955d-3377cae4c33b}

Name: Multi-process staged rollout
Version: 1.14
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0.5
Enabled: true
ID: firefox@getpocket.com

Name: Site Deployment Checker
Version: 1.0
Enabled: true
ID: deployment-checker@mozilla.org

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Name: FiddlerHook
Version: 2.5.1.8
Enabled: false
ID: fiddlerhook@fiddler2.com

Name: iCloud Bookmarks
Version: 1.4.24
Enabled: false
ID: firefoxdav@icloud.com

Name: IE Tab 2 (FF 3.6+)
Version: 6.2.18.1
Enabled: false
ID: {1BC9BA34-1EED-42ca-A505-6D2F1A935BBB}

Name: LastPass: Free Password Manager
Version: 4.1.54
Enabled: false
ID: support@lastpass.com

Name: Logitech SetPoint
Version: 6.5
Enabled: false
ID: {F003DA68-8256-4b37-A6C4-350FA04494DF}

Name: McAfee ScriptScan for Firefox
Version: 15.4.0
Enabled: false
ID: {D19CA586-DD6C-4a0a-96F8-14644F340D60}

Name: OpenDownload²
Version: 4.1.2
Enabled: false
ID: {210249CE-F888-11DD-B868-4CB456D89593}

Name: Sharepoint Launcher
Version: 0.5
Enabled: false
ID: sharepointlauncher@meketagroup.com

Name: View in Office Online Viewer
Version: 1.3.0.1-signed.1-signed
Enabled: false
ID: viewinofficeapps@huhsiaotao

Graphics
--------

Features
Compositing: Direct3D 11
Asynchronous Pan/Zoom: none
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
WebGL2 Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
Audio Backend: wasapi
Direct2D: true
DirectWrite: true (10.0.14393.1358)
GPU #1
Active: Yes
Description: Intel(R) HD Graphics Family
Vendor ID: 0x8086
Device ID: 0x0a16
Driver Version: 20.19.15.4531
Driver Date: 9-29-2016
Drivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
Subsys ID: 05cb1028
RAM: Unknown

Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: skia
Decision Log
D3D9_COMPOSITING:
disabled by default: Disabled by default
GPU_PROCESS:
unavailable by runtime: Multi-process mode is not enabled




Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 204800
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.hashstats_reported: 1
browser.cache.disk.smart_size_cached_value: 200000
browser.cache.disk.smart_size.enabled: false
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 4
browser.download.importedFromSqlite: true
browser.fixup.domainwhitelist.migcentral: true
browser.places.smartBookmarksVersion: 8
browser.sessionstore.upgradeBackup.latestBuildID: 20170403072723
browser.startup.homepage: http://www.google.com/
browser.startup.homepage_override.buildID: 20170403072723
browser.startup.homepage_override.mstone: 53.0
browser.urlbar.daysBeforeHidingSuggestionsPrompt: 0
browser.urlbar.lastSuggestionsPromptDate: 20170814
browser.urlbar.timesBeforeHidingSuggestionsHint: 0
dom.apps.reset-permissions: true
dom.ipc.plugins.enabled.npietab2.dll: true
dom.ipc.processCount.web: 4
dom.max_script_run_time: 0
dom.mozApps.used: true
extensions.lastAppVersion: 53.0
font.internaluseonly.changed: false
gfx.crash-guard.d3d11layers.appVersion: 53.0
gfx.crash-guard.d3d11layers.deviceID: 0x0a16
gfx.crash-guard.d3d11layers.driverVersion: 20.19.15.4531
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.status.: 2
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.d3d11video: 2
gfx.crash-guard.status.d3d9video: 2
gfx.direct3d.last_used_feature_level_idx: 0
gfx.driver-init.appVersion: 42.0
gfx.driver-init.deviceID: 0x0a16
gfx.driver-init.driverVersion: 10.18.14.4170
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
layers.mlgpu.sanity-test-failed: false
media.gmp-eme-adobe.abi: x86-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1463101706
media.gmp-eme-adobe.version: 17
media.gmp-gmpopenh264.abi: x86-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1507665785
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20170403072723
media.gmp-manager.lastCheck: 1508349076
media.gmp-widevinecdm.abi: x86-msvc-x64
media.gmp-widevinecdm.lastUpdate: 1508349077
media.gmp-widevinecdm.version: 1.4.8.903
media.gmp.storage.version.observed: 1
media.hardware-video-decoding.failed: false
media.webrtc.debug.log_file: C:\Users\bwalker1\AppData\Local\Temp\WebRTC.log
network.auth.allow-subresource-auth: 2
network.automatic-ntlm-auth.trusted-uris: helpdesk,gr
network.cookie.prefsMigrated: true
network.negotiate-auth.trusted-uris: helpdesk,gr
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1504803890
places.history.expiration.transient_current_max_pages: 122334
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.load_in_parent_process.application/ietab2: true
plugin.state.nppdf: 0
plugins.ctprollout.cohort: control
plugins.ctprollout.cohortSample: 0.847864
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.migrateFx3Prefs: true
security.disable_button.openCertManager: false
security.sandbox.content.tempDirSuffix: {9f4dd502-e4e5-4737-b5e9-4e21038ee48b}
services.sync.declinedEngines:
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1503495691
ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.13.1
Version in use: 4.13.1

NSS
Expected minimum version: 3.29.3
Version in use: 3.29.3

NSSSMIME
Expected minimum version: 3.29.3
Version in use: 3.29.3

NSSSSL
Expected minimum version: 3.29.3
Version in use: 3.29.3

NSSUTIL
Expected minimum version: 3.29.3
Version in use: 3.29.3

Experimental Features
---------------------

Sandbox
-------

Content Process Sandbox Level: 1

Comment 18

2 months ago
Thanks Brad for providing the requested info.

Based on comment 17, Ehsan's theory seems correct and e10s is the cause of this issue. I'm moving it to Core:: Layout: Form Controls.
Component: General → Layout: Form Controls
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → bug 1118086
(Reporter)

Comment 19

2 months ago
Hello, is this something that will be patched in a future version? I am worried that at some point my workaround of adding an add-on to Firefox will not resolve the issue. Thanks, Brad
Brad, do you have steps to reproduce the crash? I don't find URL info in your crash reports.

Updated

13 days ago
Priority: -- → P3
(In reply to Brad Walker from comment #19)
> Hello, is this something that will be patched in a future version? I am
> worried that at some point my workaround of adding an add-on to Firefox will
> not resolve the issue. Thanks, Brad

Yes. The work is in progress now. As comment 20, it would be great if you can provide a test case or steps to reproduce so that we can verify it upon completion.
Flags: needinfo?(bwalker)

Comment 22

13 days ago
(In reply to Astley Chen [:astley] (UTC+8) from comment #21)
> As comment 20, it would be great if you
> can provide a test case or steps to reproduce so that we can verify it upon
> completion.

A simple Select with 10000 Options is enough to hang the browser for some seconds, when clicking on it.
Here a fiddle:
https://jsfiddle.net/291e0zLy/
In Bug 1118086 Comment 87, mats proposed that we should render the dropdown menu in the content process. That will resolve the performance issues, the styling issues, and I'm working on it in Bug 1421229. I tried the test case in comment 22, and the performance is really well.
(Reporter)

Comment 24

7 days ago
(In reply to Astley Chen [:astley] (UTC+8) from comment #21)
> (In reply to Brad Walker from comment #19)
> > Hello, is this something that will be patched in a future version? I am
> > worried that at some point my workaround of adding an add-on to Firefox will
> > not resolve the issue. Thanks, Brad
> 
> Yes. The work is in progress now. As comment 20, it would be great if you
> can provide a test case or steps to reproduce so that we can verify it upon
> completion.
.  
Hello, I don't seem to be having drop-down issues anymore since the upgrade to Firefox 57.  I will let you know if the issue reoccurs. Thank you for your assistance
Flags: needinfo?(bwalker)

Updated

7 days ago
status-firefox57: ? → unaffected

Comment 25

7 days ago
Firefox 57.0.1 and even the 59.0a1 (2017-12-03) need at least 3 seconds to load the 10000 options (comment #22).
Tested Mac and Windows.
Pre e10s FX and other browsers don't have a problem with that.
(Reporter)

Comment 26

7 days ago
(In reply to Chris from comment #25)
> Firefox 57.0.1 and even the 59.0a1 (2017-12-03) need at least 3 seconds to
> load the 10000 options (comment #22).
> Tested Mac and Windows.
> Pre e10s FX and other browsers don't have a problem with that.

I am seeing that issue as well
You need to log in before you can comment on or make changes to this bug.