The tour icon disappears when the overlay is opened in high contrast mode

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
3 months ago
3 months ago

People

(Reporter: Abe_LV, Unassigned, NeedInfo)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(Reporter)

Description

3 months ago
Steps to Reproduce:

Screen capture: https://testing-1.tinytake.com/sf/MTk0NjU0MF82MTgyNTcx

1. Set browser.display.document_color_use=2
2. Open new tab
3. Observer the Mozilla/tour/ icon
4. Click on the icon and observe the icon while the layover is opened.

Actual Result:
3. Mozilla icon does not have a blue dot.The icon now has a white dot.
4. The icon itself disappears when the overlay is opened.

Expected Result:
3. The icon should have a blue dot.
4. The icon should be visible when the overlay is opened.
(Reporter)

Updated

3 months ago
Flags: needinfo?(mverdi)
QA Contact: jwilliams
Whiteboard: [photon-onboarding]

Comment 1

3 months ago
Put some explanations:
(In reply to Abe - QA (:Abe_LV) from comment #0)
> Steps to Reproduce:
> 
> Screen capture: https://testing-1.tinytake.com/sf/MTk0NjU0MF82MTgyNTcx
> 
> 1. Set browser.display.document_color_use=2
> 2. Open new tab
> 3. Observer the Mozilla/tour/ icon
> 4. Click on the icon and observe the icon while the layover is opened.
> 
> Actual Result:
> 3. Mozilla icon does not have a blue dot.The icon now has a white dot.
This is because the background color is stripped of by the high contrast mode. It seems that's the high contrast mode's purpose to reduce the complexity on the visual aspect as much as possible for visually impaired users.

> 4. The icon itself disappears when the overlay is opened.
> 
> Expected Result:
> 3. The icon should have a blue dot.
> 4. The icon should be visible when the overlay is opened.
The onboarding icon button is below the overlay and not clickable.
The icon button could be seen(still clearly it is below the overlay) when the overlay opens in the default mode is because the overlay background gains some transparency. It could not be seen in the high contrast mode because of no transparency in the high contrast mode. Maybe no visibility to some degree could reduce some confusion for visually impaired users because it would be quite clear that is not clickable.
Whiteboard: [photon-onboarding] → [photon-onboarding][photon-onboarding-newui][triage]

Comment 2

3 months ago
per triage, both cases are considered as desirable behavior in high contrast mode.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
Whiteboard: [photon-onboarding][photon-onboarding-newui][triage]
You need to log in before you can comment on or make changes to this bug.