Closed Bug 1399178 Opened 2 years ago Closed 2 years ago

Weird effect on arstechnica when scrolling to the top (OMTP)

Categories

(Core :: Graphics, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- unaffected

People

(Reporter: milan, Assigned: bas.schouten)

References

(Blocks 1 open bug)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

https://arstechnica.com/science/2017/08/after-43-years-gentle-touch-of-a-neutrino-is-finally-observed/ scroll (mouse wheel or scroll bar) away from the top, then scroll all the way to the top.  With the scrollbar, the text in the first paragraph is black "bounding box" rectangles until I let go of the mouse button.

I'll look for a regression range.
What OS and version did you see this on?
This is Windows 10, and it feels like it's something that the site is doing (e.g., looks like what facebook does when they're loading.)  Not successful with mozregression so far, so I'm not sure how actionable this would be.
This page has also gone to "spinning forever" at times, and I also managed to get the boxes to be white/not show.  The boxes are per line of text, not per word.
I am, however, running OMTP enabled, let me see if that makes a difference.
OMTP only.
Blocks: omtp
Priority: -- → P3
Summary: Weird effect on arstechnica when scrolling to the top → Weird effect on arstechnica when scrolling to the top (OMTP)
Whiteboard: [gfx-noted]
Component: Panning and Zooming → Graphics
Comment on attachment 8907763 [details]
Bug 1399178: Record SetPermitSubpixelAA.

https://reviewboard.mozilla.org/r/179428/#review184604

::: gfx/2d/DrawTargetCapture.cpp:85
(Diff revision 1)
>  void
> +DrawTargetCaptureImpl::SetPermitSubpixelAA(bool aPermitSubpixelAA)
> +{
> +  AppendCommand(SetPermitSubpixelAACommand)(aPermitSubpixelAA);
> +
> +  // Have to update the transform for this DT

s/transform/subpixel AA state/
Attachment #8907763 - Flags: review?(dvander) → review+
Backout by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/mozilla-inbound/rev/79eb1b3a2928
Backed out changeset 8cd211d1292e for unexpected passes on quantumrenderer, e.g. in reftest layout/reftests/counters/counter-suffix-ref.html. r=backout
So I fixed one of your bugs, could you reland this marking the relevant QR tests passing?
Flags: needinfo?(bas) → needinfo?(jmuizelaar)
I did this, since I had to update the webrender reftest tracking spreadsheet anyway.

Try push to verify greenness: https://treeherder.mozilla.org/#/jobs?repo=try&revision=29dbd61db4e93cf3de6376598dabd80c94f685af

Will land if that looks good.
Flags: needinfo?(jmuizelaar)
https://hg.mozilla.org/mozilla-central/rev/14913071baca
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Assignee: nobody → bas
You need to log in before you can comment on or make changes to this bug.