Closed Bug 1399245 Opened 2 years ago Closed 2 years ago

Sync shield-recipe-client v75 from GitHub (commit 321e8fb )

Categories

(Firefox :: Normandy Client, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: osmose, Assigned: osmose)

References

Details

Attachments

(2 files)

There have been 2 PRs since the last sync (bug 1397415) that affected the add-on:

- #1037: Fix #1036: Remove OSX-specific close button CSS for Heartbeat bar.
  https://github.com/mozilla/normandy/pull/1037

- #1058: Fix #1058: Bind PreferenceExperiment driver functions. 
  https://github.com/mozilla/normandy/pull/1060

Instead of a single sync patch, I'm going to see if attaching per-commit patches will work better.

#1058 needs to be uplifted to Beta after it lands since it's a bug in the fix for bug 1371350 that got uplifted to Beta in the last sync.
Assignee: nobody → mkelly
Comment on attachment 8907268 [details]
Sync Bug 1399245: Fix mozilla/normandy#1036: Remove OSX-specific close button CSS for Heartbeat bar.

https://reviewboard.mozilla.org/r/178944/#review184050
Attachment #8907268 - Flags: review?(gijskruitbosch+bugs) → review+
Comment on attachment 8907269 [details]
Sync Bug 1399245: Fix mozilla/normandy#1058: Bind PreferenceExperiment driver functions.

https://reviewboard.mozilla.org/r/178946/#review184052
Attachment #8907269 - Flags: review?(gijskruitbosch+bugs) → review+
(In reply to Michael Kelly [:mkelly,:Osmose] from comment #0)
> There have been 2 PRs since the last sync (bug 1397415) that affected the
> add-on:
> 
> - #1037: Fix #1036: Remove OSX-specific close button CSS for Heartbeat bar.
>   https://github.com/mozilla/normandy/pull/1037
> 
> - #1058: Fix #1058: Bind PreferenceExperiment driver functions. 
>   https://github.com/mozilla/normandy/pull/1060
> 
> Instead of a single sync patch, I'm going to see if attaching per-commit
> patches will work better.

It does work a little better, but that's in part because there's not a lot of them, and they're relatively small. :-)
Pushed by mkelly@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f2bd9e8d0975
Sync Bug 1399245: Fix mozilla/normandy#1036: Remove OSX-specific close button CSS for Heartbeat bar. r=Gijs
https://hg.mozilla.org/integration/autoland/rev/9771577eeeae
Sync Bug 1399245: Fix mozilla/normandy#1058: Bind PreferenceExperiment driver functions. r=Gijs
Comment on attachment 8907269 [details]
Sync Bug 1399245: Fix mozilla/normandy#1058: Bind PreferenceExperiment driver functions.

Approval Request Comment
[Feature/Bug causing the regression]:
https://github.com/mozilla/normandy/issues/1058

[User impact if declined]:
Users will see an error in the browser console when preference experiment recipes run. Luckily, this shouldn't (in theory) otherwise affect our ability to run experiments, since we also write this data on shutdown.

There is a medium-to-low chance that this may also have an effect on bug 1399936 as it is related to how we save the preferences for experiments between sessions.

[Is this code covered by automated tests?]:
Yes

[Has the fix been verified in Nightly?]:
I have manually verified the latest Nightly against a local copy of the Shield experiment server.

[Needs manual test from QE? If yes, steps to reproduce]: 
No

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
Very minor code change, covered by new tests added with the patch.

[String changes made/needed]:
None
Attachment #8907269 - Flags: approval-mozilla-release?
Marking 56 as affected since we intend to uplift this for the RC build.
Comment on attachment 8907269 [details]
Sync Bug 1399245: Fix mozilla/normandy#1058: Bind PreferenceExperiment driver functions.

New shield recipe to put into place for 56 release.
Attachment #8907269 - Flags: approval-mozilla-release? → approval-mozilla-release+
Product: Shield → Firefox
You need to log in before you can comment on or make changes to this bug.