cannot import profile from mozilla on previous windows installation

VERIFIED DUPLICATE of bug 137006

Status

Core Graveyard
Profile: Migration
VERIFIED DUPLICATE of bug 137006
16 years ago
2 years ago

People

(Reporter: Adam Katz, Assigned: racham)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nr])

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Mozilla1.00rc1 release, Windows2000, build 2002041711
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1) Gecko/20020417

mozilla remembers settings after I copy old settings but removes prefs.js and
bookmarks.html once either is changed. (my older build was either the same or
something else on the same branch).

produce by:
-copy "\Documents and Settings\username\Application Data\Mozilla" to another
location.
-install windows 2000 from scratch (NOT update or bundled CD)
-install mozilla
-copy back the directory from first step
-run mozilla profile manager, choose older profile
-profile manager spawns mozilla, with bookmarks and prefs intact
-change a preference (i changed cache dir location)
-error dialog pops up: "Failed to save the preferences file. Any preference
changes will be lost at the end of this session."
-bookmarks and prefs reset to default, cookies and everything else intact
-reproduce by performing above directions starting at third or fourth step.

expected:
-smooth integration; no errors or reset prefs/bookmarks


this new install did/does not have ns4.x.
I apologize, but I lack the resources (ie time) to test the initial production
process (reinstall windows) but I have tried reinstalling mozilla, copying, etc
to no avail.  

perhaps this is a problem with prefs.js having hard-coded locations in it (which
it shouldn't)?

proposed solution:
Import option on profile manager that allows current and older mozilla and ns
profiles stored in weird places

This is a mozilla->mozilla  Profile Migration problem. 
This is NOT a ns4->mozilla  Profile Migration problem.
(Reporter)

Comment 1

16 years ago
Created attachment 80887 [details]
error dialog on top of preferences window upon hitting OK
(Reporter)

Comment 2

16 years ago
possibly related to bug 137164  

also, I am using the old profile right now.  Even after the replacement of my
prefs and bookmarks, I cannot save either.  Neither file exists and any files
placed there get removed my mozilla.

Comment 3

16 years ago
Reporter,

Are you upgrading your OS to Win2000 or just reinstalling it?  
(Reporter)

Comment 4

16 years ago
reinstalled, not upgraded.

Comment 5

15 years ago
There is another bug for requesting Import feature - which indeed would be useful. 
see bug 87145

I cannot reproduce this on my Win2000 machine (I am working as Administrator)-
with a build from 11/18.  
This also looks suspiciously like bug 155080 where prefs.js is reset to default
values.

cc'ing sairuh- seen anything like this?
reporter, can you reproduce on a more recent build?
Whiteboard: [nr]

Comment 6

15 years ago
> perhaps this is a problem with prefs.js having hard-coded locations in it (which
> it shouldn't)?

it didn't, but does now more than before (work continues).  see bug 12911 and
bug 157662.

it seems likely that the absolute paths in the prefs would be sufficient to
screw things up and lead to the behavior described here.

marking dupe of bug 157662 where work on relative paths continues.  please
reopen if you believe there are outstanding issues not covered by that bug.

*** This bug has been marked as a duplicate of 157662 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
dup'd to wrong bug. bug 137006 would be correct; reopening to do that.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 137006 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.