HTTPS / SSL Connections Requiring a Client Certificate Fail

RESOLVED FIXED in Firefox 57

Status

()

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: bws42, Unassigned)

Tracking

({regression})

Trunk
mozilla57
regression
Points:
---

Firefox Tracking Flags

(thunderbird_esr52 unaffected, firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57- fixed)

Details

(Reporter)

Description

a year ago
My first visit to a site that requires a client certificate always fails with an SSL_ERROR_HANDSHAKE_FAILURE_ALERT. A page I keep open that refreshes every 5 minutes will eventually fail as well, but succeed immediately if I refresh it.

This changeset works: 50857982881ae7803ceb438fee90650a282f7f05
This changeset does not: c71b01e993510268bab7d60154b2f80692fd507d

#910207 landed in that window and deals with client certificates
(Reporter)

Updated

a year ago
Blocks: 910207
Thanks for the regression range, very helpful!

[Tracking Requested - why for this release]: Regression from bug 910207

Leaving status-firefox56: ? since it's not currently affected but will be if bug 910207 gets uplifted.
Has Regression Range: --- → yes
status-firefox55: --- → unaffected
status-firefox56: --- → ?
status-firefox-esr52: --- → unaffected
status-thunderbird_esr52: --- → unaffected
tracking-firefox57: --- → ?
Flags: needinfo?(valentin.gosu)
Flags: needinfo?(dkeeler)
Keywords: regression
I backed out bug 910207. Will fix and land again in bug 910207.
Flags: needinfo?(valentin.gosu)
Flags: needinfo?(dkeeler)
I'll call this fixed by the backout.
status-firefox56: ? → unaffected
status-firefox57: affected → fixed
tracking-firefox57: ? → -
Target Milestone: --- → mozilla57
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.