Documentation needs update about being unable to open about:newtab via browser.tabs.create

RESOLVED FIXED

Status

WebExtensions
General
RESOLVED FIXED
9 months ago
18 hours ago

People

(Reporter: gkw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/tabs/update

states that about:newtab is an unprivileged about: page.

However, the following page makes no mention:

https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/tabs/create

I tested that about:blank, about:logo etc. are able to be opened, but not about:config, as intended.

I was unable to open about:newtab, so it seems it is privileged. Bug 1346059 confirms that we are unable to open about:newtab.

Should the documentation be updated?

Tested on Fx 55.

Comment 1

9 months ago
On the page:

https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/tabs/create

It says:

"url Optional string. The URL to navigate the tab to initially. Defaults to the New Tab Page."

I've added a note about:newtab to make it more explicit. MDN is a Wiki, anyone can edit, so if you think it needs more please add it in.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED

Updated

18 hours ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.