Closed Bug 1399397 Opened 2 years ago Closed 2 years ago

Search arrow does not respond to clicks after a Top Site or Highlight is dropped in the Search Bar

Categories

(Firefox :: New Tab Page, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox57 --- verified
firefox59 --- verified

People

(Reporter: cmuresan, Assigned: ahillier)

References

Details

Attachments

(2 files)

[Affected versions]:
- Firefox 57.0a1 Build ID 20170904220027

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- browser.newtabpage.activity-stream.enabled is set to true in about:config on a clean new profile.

[Steps to reproduce]:
1. Start the browser with the profile from prerequisites and open a New Tab.
2. Drag a Top Site in the Search bar.
3. Click the "Search" arrow and observe the behavior.

[Expected results]:
- The search is performed with the default search engine.

[Actual results]:
- The search is not started.

[Notes]:
- The issue is also reproducible if you drag a Pocket card or a Highlight card.
- The issue is not reproducible if you press Enter after following the steps.
- Attached a screen recording of the issue.
Comment on attachment 8907802 [details]
Bug 1399397 - Fix ActivityStream search when a link is dragged into the search-bar.

https://reviewboard.mozilla.org/r/179494/#review184656
Attachment #8907802 - Flags: review?(edilee) → review+
Pushed by edilee@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/dc6acc3b9707
Fix ActivityStream search when a link is dragged into the search-bar. r=Mardak
https://hg.mozilla.org/mozilla-central/rev/dc6acc3b9707
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
QA Whiteboard: [good first verify]
I have reproduced this bug with Nightly 57.0a1 (2017-09-13) on Ubnuntu 16.04 LTS!

This bug's fix is verified with latest Beta!

Build ID   : 20171005195903
User Agent : Mozilla/5.0 (X11;Linuxx86_64; rv:57.0) Gecko/20100101 Firefox/57.0
QA Whiteboard: [good first verify] → [good first verify] [bugday-20171004]
I have reproduced this bug with Nightly 57.0a1 (2017-09-13) on Windows 10 , 64 Bit ! 

This bug's fix is Verified with latest Beta !

Build   ID    20171009192146
User Agent    Mozilla/5.0 (Windows NT 10.0; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

[bugday-20171011]

I have Reproduced this bug with Nightly 59.0a1 (2017-12-10) on Windows 10, (64-bit)

Status: Fixed & Verified 

Useragent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0 
BuildID: 20171210220040

[testday-20171208]
Assignee: nobody → a.hillier
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.