Closed Bug 1399438 Opened 3 years ago Closed 3 years ago

Funsize submits jobs to Treeherder using deprecated revision_hash taskcluster route

Categories

(Release Engineering :: Release Automation: Other, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1399440

People

(Reporter: emorley, Unassigned)

Details

The Treeherder revision_hash concept has been deprecated for a while, and we're hoping to remove it soon in bug 1257602 - however looking at the New Relic stats I see funsize jobs that are using a revision_hash instead of a revision.

The revision hash is being generated here:
https://github.com/mozilla-releng/funsize/blob/e091471ffca545c0639f7f60cd1be3427f6969b9/funsize/worker.py#L589-L594

And ends up in the task template here:
https://github.com/mozilla-releng/funsize/blob/96d4d90350a8a1ee378f1b0dddfcd45acd4bff53/funsize/tasks/funsize.yml#L36-L37

I'm presuming the task should be switched to using the v2 route (and use `revision` not `revision` hash in the route name), something like here:
https://github.com/mozilla/gecko-dev/blob/e0340aa82f7431c6906857865d064d6bcf3ed187/.taskcluster.yml#L43

Rail, I don't suppose you'd be able to take a look? :-)
Dupe bug caused by bug 1399442.
No longer blocks: 1257602
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1399440
You need to log in before you can comment on or make changes to this bug.