Closed Bug 1399461 Opened 2 years ago Closed 2 years ago

Nearly-permafailing css-break/box-decoration-break-with-outset-box-shadow-1.html == css-break/box-decoration-break-with-outset-box-shadow-1.html | image comparison, max difference: 45, number of differing pixels: 439

Categories

(Core :: Layout: Block and Inline, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox57 --- fixed

People

(Reporter: intermittent-bug-filer, Unassigned, NeedInfo)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed:backout])

Duplicate of this bug: 1399479
This started with this merge to m-c from inbound: https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=9873269746359dbcccbd5b44f0e82c0225289945

Sadly, these jobs only run on autoland, m-c and try, so I can't see when it started on inbound.

This is pretty close to permafailing. (I see maybe 4 out of 27 green rs4  jobs on autoland today since the merge.)
Summary: Intermittent css-break/box-decoration-break-with-outset-box-shadow-1.html == css-break/box-decoration-break-with-outset-box-shadow-1.html | image comparison, max difference: 45, number of differing pixels: 439 → Nearly-permafailing css-break/box-decoration-break-with-outset-box-shadow-1.html == css-break/box-decoration-break-with-outset-box-shadow-1.html | image comparison, max difference: 45, number of differing pixels: 439
Why do these jobs not run on mozilla-inbound?
(And how does one trigger them to run on mozilla-inbound?)
Matt, your changes seem the most likely cause, I think...
Flags: needinfo?(matt.woodrow)
(In reply to David Baron :dbaron: ⌚️UTC-7 (catching up on backlog from vacation) from comment #4)
> Why do these jobs not run on mozilla-inbound?

IIRC, When stylo was set up, it was tier-2 and capacity issues had people lean toward running them on as few trees as possible. Since the only things that would theoretically break stylo would be the landings from the servo repo which only happen on autoland, it was decided that we didn't need to run them on inbound.

I think it's probably time to reconsider that, since non-servo merges can clearly break stylo tests.

(In reply to David Baron :dbaron: ⌚️UTC-7 (catching up on backlog from vacation) from comment #5)
> (And how does one trigger them to run on mozilla-inbound?)

I believe you can still manually add them to a push on inbound by signing in to Treeherder, filtering down to "rs4" in the textbox in Treeherder's header, and then clicking the "Add new jobs" button in the per-push menu for the desired pushes. 

After a few seconds, you should see a few new rs4 jobs appear for the push. Click the linux64 version of the job, then click the "Trigger new jobs" button in the per-push header and confirm the prompt that appears. After a few minutes, you should see the actual job start running on the push.

You could also try pushing various revisions from inbound in the regression range to try, only requesting these jobs to run, then check those results in a few hours. Linux64 should finish decently quickly.
Filed bug 1399742 for trying to get these jobs scheduled on inbound.
I've triggered the rs4 job on inbound using the steps I mentioned and requested a 50-push backfill, which hopefully will be enough to get to where the failure started. I might be up long enough to monitor things and backfill further if needed.
Got bored, pushed things to try...

So the tip of the current regression range is with a backout of just bug 1397056. Test fails.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=514131daf5fd08a4722bca5b86c62c2e0f741d28 will be the tip of the regression range, plus a backout of bug 1397060. Jury's still out on that one.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=34c56848b03f54f9b9587582ae38e1932593973c will be the prior try push, but bug 1397058 is also backed out. No results yet.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=e9a20bf2db60dc4e74d695e3a9f331e3618053a0 will be the prior try push, but bug 1397057 is also backed out. Nothing yet here.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ab393c505a66529ae2c5ee5e818ee05ea619e510 will be all of Matt's commits from that push backed out. No results yet.

Hope that helps, I'm gonna go sleep now.
Thank you for the Try pushes. Fixed by the backouts of bug 1397058 and bug 1397060.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Whiteboard: [stockwell fixed:backout]
You need to log in before you can comment on or make changes to this bug.