”Ok!” button from extension installation pop-up in gray

VERIFIED FIXED in Firefox 56

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: vasilica.mihasca, Assigned: johannh)

Tracking

({regression})

Trunk
Firefox 57
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 verified, firefox57 verified)

Details

Attachments

(4 attachments)

Posted image 2017-09-13_1620.png
[Affected versions]:
Firefox 57.0a1 (20170913100125)
Firefox 56.0b11 (20170911193316)

[Affected platforms]:
Windows 10 64-bit
Mac OS X 10.12.3
Ubuntu 16.04 32-bit

[Steps to reproduce]:
1.Launch Firefox with a clean profile.
2.Try to install the following complete theme: https://addons.mozilla.org/en-US/firefox/addon/walnut2-for-firefox/?src=cb-dl-users
3.Check the “OK!” button from extensions installation pop-up.

[Expected Results]:
The “OK!” installation pop-up button is blue.


[Actual Results]:
- The “OK!” button is gray.
- See attached screenshot


[Regression Range]:
Last good revision: 2af9cfda0d5c1a8821d1640d8185ae0985383fd3
First bad revision: 5ead094a4792105cbdc4ced7424230e8e345a13b
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=2af9cfda0d5c1a8821d1640d8185ae0985383fd3&tochange=5ead094a4792105cbdc4ced7424230e8e345a13b

Looks like the following bug has the changes which introduced the regression: Bug 1377006
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1399172
Posted image 2017-09-15_1149.png
This issue is not a dupe of Bug 1399172 because it is still reproducible on Firefox 57.0a1 (20170914220209) and Firefox 56.0b12 (20170914024831).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 3

2 years ago
Has something from some other style changes changed this? Johann might know...
Flags: needinfo?(jhofmann)
Huh, its true that didn't get fixed.
The notification is created from here if its helpful:
http://searchfox.org/mozilla-central/rev/2c9a5993ac40ec1db8450e3e0a85702fa291b9e2/browser/base/content/browser-addons.js#402-403
Component: Add-ons Manager → Site Identity and Permission Panels
Product: Toolkit → Firefox
Sorry for that, I'll look into it. Leaving ni on as a reminder.
The weird thing is that this is only happening with the error dialog, not with the success dialog (at least for me). Fortunately that makes the bug also less impactful, in my view. We'll probably not be able to sneak a fix into 56 at this point, but we can fix it for 57.
Assignee: nobody → jhofmann
Status: REOPENED → ASSIGNED
Flags: needinfo?(jhofmann)
Priority: -- → P1
Comment hidden (mozreview-request)

Comment 8

2 years ago
mozreview-review
Comment on attachment 8908992 [details]
Bug 1399478 - Fix buttonhighlight for doorhangers without a mainaction.

https://reviewboard.mozilla.org/r/180604/#review185824

Looks good, soory I missed the default ok button case.
BTW shouldn't we need a test for default button as well?
Attachment #8908992 - Flags: review?(schung) → review+
Comment hidden (mozreview-request)
(In reply to Steve Chung [:steveck] from comment #8)
> BTW shouldn't we need a test for default button as well?

Good idea, I added some assertions to the test for the default button.

Thanks!

Comment 11

2 years ago
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/90237bd98dae
Fix buttonhighlight for doorhangers without a mainaction. r=steveck

Comment 12

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/90237bd98dae
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Comment on attachment 8908992 [details]
Bug 1399478 - Fix buttonhighlight for doorhangers without a mainaction.

Approval Request Comment
[Feature/Bug causing the regression]: 1377006
[User impact if declined]: The default action button color would be wrong
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Not yet
[Needs manual test from QE? If yes, steps to reproduce]:
1.Launch Firefox with a clean profile.
2.Try to install the following complete theme: https://addons.mozilla.org/en-US/firefox/addon/walnut2-for-firefox/?src=cb-dl-users
3.Check the “OK!” button from extensions installation pop-up. 
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: It should only affect the color of the default main action button and no further side effect could be introduced in the patch.
[String changes made/needed]: N/A
Attachment #8908992 - Flags: approval-mozilla-release?
I have reproduced this bug with Nightly 57.0a1 (2017-09-13) on Ubuntu 16.04, 64 bit!

The fix is now verified on Latest Nightly 57.0a1 .

Build ID 	20170919100405
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
QA Whiteboard: [bugday-20170920]
I have successfully reproduced this bug with Nightly 57.0a1 (2017-09-13)  on windows 10 (32-bit)

this bug is verified fix with  latest nightly 57.0a1 (2017-09-19) (32-bit)

Build ID: 20170919100405
Mozilla/5.0 (Windows NT 10.0; rv:57.0) Gecko/20100101 Firefox/57.0

[bugday-20170920]
As per Comment 14 and Comment 15, I am marking this bug as verified fixed.
Status: RESOLVED → VERIFIED
Comment on attachment 8908992 [details]
Bug 1399478 - Fix buttonhighlight for doorhangers without a mainaction.

Fix for button color, looks like a minor change in UI for popups on a new feature. 
This can land for the 56 RC2 build.
Attachment #8908992 - Flags: approval-mozilla-release? → approval-mozilla-release+
Posted image 2017-09-22_1539.png
Confirm that the “OK!” button is blue also on Firefox 56.0 RC build 3 (20170921234614) under Windows 10 64-bit and Mac OS X 10.12.3.
You need to log in before you can comment on or make changes to this bug.